Internet stops working if connected via mobile network (Blokada 5 on Android 10)

Hello Community!

I’m running Blokada 5.10 (downloaded from F-Droid) on Android 10 (more or less stock Android, because it is a Fairphone 3). Blokada works fine, if it is connected via WiFi. But if I switch to the mobile network (PennyMobil, a reseller of Congstar respectively Telekom Germany) not any internet connection of any app is established.
I use the blocklists “Energized Blu” and “DuckDuckGo”. In “All networks” and also in mobile and WiFi networks I use “Encrypt DNS” and “Digitale Gesellschaft” and “Use Blokada DNS in Plus mode”; “Prefer network DNS” is deactivated.
“Battery optimization” is switched off for Blokada, “Keep alive” is on, VPN is permanently switched on, “Private DNS” is off.

I tried different options to solve the problem: Change the DNS, switch off its encryption, switch off the DNS for “Any mobile network”, deactivate and reactivate Blokada. But nothing worked. The only solution is to switch off Blokada totally.

I searched this forum and the web, and the hints I found were this:

(More links are limmited by community guidelines.)

That points to a general problem with the Telekom network, Android 10 and alternative DNS. Maybe it is not caused by Blokada, but by changing the DNS with the App. None of the threads came to a conclusion.

I really would like to use Blokada 5. It could be a solution to switch off the alternative DNS in general, but I did not find a way to do so. Is there any? If not, would it be possible for the developers to integrate such a functionality? That could be a workaround for the described problem. And maybe there will come a day, where it is fixed by the provider.

Any ideas from anybody to solve the problem are very welcome.


1 Like

Thank you for providing more info on this problem, for the developers. As an open source community project the more input on any bug or issue is greatly appreciated.

1 Like

Have you tried to configure “prefer network dns” for that mobile network?
Also please share your log to

Hallo Karol,

I enabled “prefer network dns” and restarted the phone. After that the experience is different:

  • I checked some internet sites with my browser (Vivaldi) and they worked and ads are blocked.
  • The youtube app also worked.
  • The weather app (WetterOnline) did not work.
  • Also the recipe app (Chefkoch) failed.

I think those one-by-one cases must be related to the blocklists themselves, check what is being blocked on your Activity screen - maybe something should be whitelisted.

I disabled both of my blocklists (Energized and DuckDuckGo), but that didn’t solve the problem. Moreover if the blocklist would cause the problem, that would not explain, that everything works fine in a WiFi environment.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.