Blokada DNS preventing mobile data from working

This is on a Samsung Galaxy S10+, Android 10, Sprint, Blokada 4.8.3 from the website. I’ve been having this issue for about a week or two but only just now figured out that it was related to Blokada and specifically the DNS function. Basically, if I’m on mobile data and I have blokada’s DNS function on, nothing works. I can’t load any websites or anything. I’ve tried different DNS servers (cloudflare, google, and quad9) and none of them work but as soon as I turn off the DNS function, everything works as expected again. Does anyone have any tips to resolve this that doesn’t involve turning off the custom DNS?

Edit: I disabled Blokada and installed and used the Cloudflare app to use their DNS and it works perfectly fine on mobile data. So it’s only Blokada’s DNS that’s not working correctly.

Hey there and welcome to this forum:)
This sounds like your isp enforces its own DNS. Blokada v4 doesn’t use DoH (so encrypted DNS traffic). This is why it might now work. You could try using v5 (downloadable from our website, it is stable, but still lacks features v4 has) and check whether it works if you enable DoH (it should be enabled by default, but check it to be sure).

Other DNS works fine on the same connection. It’s only Blokada that has problems. I can use Cloudflare’s app which installs a VPN just like Blokada does to use their DNS and it works fine. It seems to be an issue with only Blokada.

That’s because Cloudflare uses DoH (means encrypted traffic). Which Blokada does as well with v5. My recommendation therefore would be: check out whether you are facing this issue if you use v5 as well.

Weird. Everything was working fine until about a week or two ago. I wonder if Sprint changed something on their end. Anyway, after a bit of work getting all of my settings and app whitelists transferred over, it seems like it might be working now. I can’t find any options for host whitelists though so that might cause me some different issues moving forward.

1 Like

Did you also install v5 or is this about v4?
Which whitelist and settings did you need to add before it worked?

Glad to hear this:)!
Yeah, stuff like this sometimes changes unfortunately…
You can whitelist specific hosts by allowing them through the Activity log. A little trick, to make sure they appear in the Activity log: just access these domains via the browser:).

1 Like

I had to install v5. But installing v5 doesn’t carry over whitelisted apps and such from v4. I have a handful of apps that I want to use that adblock lists often interfere with so I whitelist those apps. But the important thing for my original issue is apparently the change in DNS using DoH.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.