Blokada for android stops my data network

I downloaded blokada from blokada site. I have blokada V 5.
I have a OnePlus 7T Pro Mclaren edition android 10. No special roms everything is the default phone settings. On T-Mobile network.
While on Wi-Fi blokada works perfectly. But when I switch to data it doesn’t allow anything to load. I noticed when I was on data and google maps was just loading an address for me, or I couldn’t google anything it would just load. But the instant I turned off blokada everything loads just fine. My data connection still says 5G when blokada is on but it doesn’t allow the data to work. I have children and I use the Adguard DNA (Family). I saw a help forum that said it could be the private DNS settings on the phone so I turned it off and blokada worked with data on for a few days and then it stopped working with data on again. I don’t know what could be causing this. It’s been like this since I’ve pretty much had blokada almost 6 months.

Heyhey:)

It was definitely a good step to disable private DNS. Check that setting again, please. After system updates this setting often gets set back to the default value overwriting the user choice,

Additionally: AdGuard DNS doesn’t provide DoH. You could try whether this doesn’t occur if you enable a DNS with DoH.

You can select a list that blocks adult content instead of using AdGuard Family. Check this post as a reference:

Looking forward to hearing back from you:)

Thank you for your help. I checked private DNS and it’s still off. The Adguard dns family is the best dns on blokada for blocking adult content. I tested them all. Also I thought that was the issue so I tried turning off the DNS in blokada only and I still had the same problems

Thank you for checking this!

Yes, I know that other DNS do not block adult content. My question is: does that behavior occur if you select a DNS which uses DoH as well?
DoH is available since v5 so I am not sure whether you already tried it with a DoH one.

I see let me check it out and see.

1 Like

I tried it with a few. Cloud flare family. Cloud flare 1.1.1.1… open dns family, regular open DNS. All caused the same issue. When dns turned off data seems to work just fine

Thank you for checking this. You are on v5, right? What exactly do you mean with ‘turning DNS off’:)?

Yes in V5 I used to have v4 and it had the same issue then updated to V5. I mean I switched dns active to dns deactivated in blokada app

Ah, okay, but that was in v4 that you turned off DNS and used your ISPs one, because in v5 this option is no longer possible. Check this topic:


So it seems that your ISP tries to enforce it’s own DNS (sometimes) and then doesn’t allow other connections. This actually should be no problem if you enable a DoH server… but it seems to be.
Could you try to disable Blokada and set the private DNS to for example Cloudflare and check whether that works:)?

All those DNS had a [DoH] behind the name?

Oh snaps you’re right. Ok I thought it would update in app

How do I update it to V5 lol?

Haha, you got me very irritated for a moment:D
Do you use Advanced Ad blocking rules, CNAME blocking, Smart list or added own host lists?
Did you set own blocked/ allowed hosts (they will get lost while updating)?
Because these features are not yet implemented in v5 and I wouldn’t recommend upgrading yet if that are features you rely on.

Sorry, when the the V5 was announced I got an update at the same time so assumed it was it

I do have a few. But if I could run a (family) dns with data on then it seems worth it.

Don’t worry at all:D! We figured it out, didn’t we:)?
Then I recommend screenshoting (you can add them later with a bit of extra work) them and then just go to blokada.org and download v5.

Wait

Let me just check whether there are adult content doh dns servers

Thank you much appreciated

Ahh man:( there are no family content DoH provider. AdGuard has one but it doesn’t work (our devs tried it) so that one is not added and you cannot add custom DNS provider yet.
They all only provide unencrypted services…

Awe man:(. I guess I’ll just have to wait till I see that as an option for V5. Guess I’ll just need to turn off blokada when I leave the house