Cannot access the internet through mobile data when using Blokada 5 v5.18.0

I’ve downloaded Blokada 5 using F-Droid and I use Samsung Galaxy M51 on Android 11. I cannot watch YouTube or use apps that need internet access when Blokada 5 is on. However, I can do it with Wi-Fi. It’s only not working when I’m on mobile data. I’m a new user and this has been happening from the very start. I’ve tried using Blokada (not Blokada 5) from F-Droid and I can access the internet on mobile data but it doesn’t really block any ads.

App name and version: Blokada 5 v5.18.0
Device: Samsung Galaxy M51
OS: Android 11

Hi there :wave:,
It’s a common issue with Android users, you can try fixing it by disabling “private DNS” within the DNS section.
Let me know if it works

Hello, I went to system settings > connections > more connection settings > private DNS but I saw that it’s already turned off for me. I tried setting it to automatic instead but I still can’t access the internet.

Hi, I will need your log to tackle this issue.

Please do the following steps:

  1. Reproduce your problem

  2. Go to the app, tap the dots icon in the top right

  3. Tap “Share log”

  4. Send the log to


Hello. I’ve already sent it. Also, I forgot to add that Messenger is the only app that I can use when Blokada 5 is on.

1 Like

Please don’t.
So… In short: Blokada v5 works on WiFi but not on mobile data, v4 works on mobile data but not on WiFi.
Make sure not to have both apps installed at the same time and don’t use other VPN applications while using Blokada

Yeah I’ve turned it off again. Just curious what will happen if I change it to automatic.

Hi, I also sent my log just now.
Having the same issue, internet doesn’t work when on mobile data with blokada on, no issues on wifi. I used to have no issues on my past phone, samsung s8+, but i recently bought s22 ultra and changed networks so not sure if it’s the phone, newer android version or network operator.

Tried with both private dns off and automatic

What happens if you adjust the dns settings within blokada so that blokada uses your network dns on mobile data?


Well, that worked. Bit embarrassing haha, I wasn’t even aware I could click and get into that menu while trying to “fix” it today.

You’re welcome :slight_smile:
It seems like your network is enforcing its own dns.
That’s unlucky but the case sometimes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.