No internet access with blokada activated (sometimes even with it deactivated)

  1. Downloaded from your site
  2. Xiaomi Pocophone F1 with Android 11 (Pixel Rom, ported to this device, august release)
  3. Erratic beviour. On wifi works fine, at least I haven’t noticed any problems. When switching to data, sometimes works, but most of the times bloks the access (even for blokada itself). Default set up for blokada used (the one out of the box after installing). I can see (when have no internet access) that the browsers tell me all sites I try to visit are insecure. If I disable blokada, then sometimes the problem disappears. Other does not, and the fix is to uninstall the app. Then everything comes back to normal. Also after facing internet access issues, with blokada deactivated, I cannot login to my Google account.
  4. Facing the issue, since blokada was installed.
  5. Tried to clear cache, and reinstalling it. None of them worked
1 Like

More things tried, but didn’t work.

  • Installed last beta version and the problem persists (only connected to mobile data, on wifi works
  • Disabled private DNS on both, beta version and v5.16
  • Activated Ping under ‘This device’ on both, beta and v5.16

In all cases, on mobile data, the connection to any web site appears as insecure (open lock in URL), even when trying to connect to a HTTPS URL

I tried to post the app log, but exceeds the limit allowed to post.

Same problem here:
Xiaomi Mi A2 Android 10 with the July 2021 security patch.
Blokada 5.17.2

I think I found the solution,.

You need to set up an specific setting for mobile data connection

For that, go to Advanced - Networks - Any mobile connection

Activate Any mobile connection, and tap on it. Now disable encrypt DNS and select the DNS server that
u like. I’ve chosen Open DNS

The downside, is that now, the mobile data connection is a bit slower than before. I suppose it could be fixed selecting a closer DNS server to where I live


I think it works. Thanks!!

I have the same problem.
Pocophone F1, MIUI 12.0.3 (stable) by, Android security patch level 2020-12-01, Android version 10QKQ1.190828.002

Setting Any mobile connection:
Encrypt DNS: Disabled
Use DNS: Dismail or Digitale Gesellschaft (Switzerland)
Prefer network DNS: Disabled
Force Libre mode: Disabled

As soon as I switch from WLAN to mobile network, the internet connection is completely disconnected. Enabling DNS encryption or changing the DNS server did not help.

When I disable Blokada completely and set a DNS server in the Android settings, similar problems appear.

Doesn’t work :’( Any other fix to solve it?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.