„unable to resolve host“ when mobile and alternative DNS activated (not when wifi)

Where did you download Blokada from?

blokada.org, older versions (< v5.8) from apkmirror.com

Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?

Pocophone F1, MIUI Global (QEJMIXM) stable, Android Version 10 QKQ1.190828.002

Please explain the issue as detailed as possible . Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.

Blokada is „unable to resolve host“ when mobile (provider: PennyMobil). On wifi everything is fine.

I tried blokada 5.8 and 5.6 also some v4.x Uninstall, reinstall, no solution.

I can solve the problem, when I do not use alternative DNS. When I use alternative DNS Server (no matter which one), the error occures.

The blocklists are not the problem.

Private DNS is turned off.

I tried the „always on mode“ on and off – no solution.

Since when are you facing this issue?

I guess 1 - 2 weeks

1 Like

Problem not solved yet.

I also tried to configure ‘selected network’ with ‘prefere network dns’, but this does not work. Still connected to alternative dns.

In the blocklists activity everthing looks fine, the imoortant things are not blocked.

Same problem with Blokada 5.10.1

I have the exact same problem after switching to a new provider. But I am not sure if that is the root of the problem, as on the first evening with my new provider it worked fine and from then on I also got the “not able to resolve” error in the browser and also no connection in some apps. Started 3 days ago.

My (german) provider is PennyMobil (Congstar / Telekom).

Now I tried a diffrent sim-card (sim.de / Telefonica) and the problems with the alternative DNS providers were gone. It worked correctly with no problems.

So I guess, that the problem is not Blokada because:

  • some problems with the Blokada alternative App “DNS66”
  • no problems with Blokada when using a diffrent provider

Same problem, unfortunately without a solution:

So how to deal with that issue?

Anyone a good idea?

1 Like

I asked my provider (Pennymobil / Telekom) about that issue. Acually waiting for response.

That’s curious. I actually have the exact same issues with the same provider (Telekom).
I came here hoping that someone might be able to help… :sweat_smile:

OK, so as there seems to be no solution for now, I’ll have to investigate further. I’ll share any results I’ll come across.

However, here’s what I find odd:

  • Blokada worked fine the entire time on my Android 11, so I don’t see any issues with Android 10 as mentioned in the other post.
  • I thought that this issue arose after I’ve updated Blokada, but if the other versions don’t fix the issue, but a different provider does, I suppose it’s the provider’s fault.
  • I just have done a clean install of Blokada 5.10.1. Without any other configuration done, this will block my local DNS server (i.e. I can’t resolve any DNS records in my WIFI any longer)
  • Something I find particularly odd: I only have the issue if I have both WIFI and data turned on and leave my WIFI range. If I turn off WIFI (e.g. for testing purposes), I don’t have the issue.

I’ll investigate further and see what I can dig up…

Okay, so here’s what I’ve found out so far: To me, it looks like German Telekom does something suspicious with DNS. Resolving WILL work eventually, it just seems to be SUPER slow.

However, I have found a working configuration:

  • Fresh install of Blokada 5
  • In Blokada, go to “Advanced”, Networks, All networks
  • Disable “Encrypt DNS”
  • Tap the “Use DNS: …” entry, select Google
  • Again tap the “Use DNS: …” entry, scroll all the way down, disable “Use Blokada DNS in Plus mode”

This way, I still get reasonable DNS resolving speeds, local DNS resolving in WIFI connections and still blocking in Blokada 5. However, what I don’t get (obviously) is encrypted DNS. Not sure about the Google DNS server however, might work with others as well.

I don’t think the “Plus mode” flag actually does anything, as I’ve understood that it would be relevant in VPN (i.e. Plus) mode only. However, it seems that it’s mandatory to disable this in order to get a working setup. I wonder why that is.

Also, I wonder why “Encrypted DNS” won’t work, because from what I’ve understood, this would use https and should work virtually everywhere.

@shack Can you confirm my settings working for you as well?

@Karol, maybe you can shed some light on this?


I don’t have a slow connection. I don’t have any connction.

Uninstalled Bloakda, rebooted mobile phone, installed Blokada 5.10.1, diasabled “encrypt DNS”, selected “Google DNS”, disabled “Use Blokada DNS in Plus mode”.

When I disable WIFI and switch to mobile network: same error as already described.

Uninstalled Blokada 5.10.1, installed Blokada 4.11 without DNS activation → everything works fine.

No answer from Telekom yet.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.