Complete DNS failure after frequent switching between WiFi and Mobile networks

Sure
That’d be awesome :smiley:

Thank you very much for the replies. I will also try to get a log and share it.

Actually, I have got two Android phones (Samsung and Pixel), both on Android 11.
For both phones, most of the time the individual wlan-network is not recognized, it stay on “all-wlan-networks”. But that is - for me - not an urgent issue. Even though, it would be nice, if the wlan recognition worked correctly.

The real problem happens only with the Pixel 3a, when switching from wlan to mobile network. Blokada remains often on “all wlan networks” without having wlan-connectivity or even with “wlan” in the phone’s menu turned off and only the mobile network turned on. The phone then looses connectivity (due to missing dns resolution). Only, hard stop and restart of the blokada application helps. That makes blokada difficult to be used on the Pixel.

I’ll try to share a log. Thank you very much for the effort and the great app!

Thank you again.

I’ve now sent in two emails (yesterday). Did you get them please?

This problem is really annoying, I’m thinking of reinstalling version 4 again :frowning:

Hello,
Unluckily troubleshooting and log checking isn’t some type of wizardry which can be completed within a few minutes. Feel free to install V4 while we analyse this

I am having the same issue on two separate Pixel 4A 5g devices. I’ve tried different DNS servers without success.

Not every time, but often, when I such between wifi and cell, data will stop working. Toggling blokada off then makes the data work. If I then re-enable blokada, it works fine.

I was using the version right before 5.10.1 which also has the same DNS selection menu and I didn’t notice the issue.

I’d be happy to provide logs if that would help.

Studying the log of the Pixel phone, I recognize two main problems:

  1. name detection not working:
    Connectivi Wifi network fallback name detection returned null
    Connectivi Network up: 987987878979877, (null, type=WIFI)

  2. Detection of “network down” in case of wifi is sometimes not working. E.g. when wifi is manually turn off and cell is turned on, blokada’s block shows only the following entries (even after wifi been turned off):

Connectivi Network up: 786786876876, (XXX, type=CELLULAR)
W Connectivi Guessing which wifi network to use: (null, type=WIFI)

Then connectivity is lost, due to missing dns resolution.

For the record, my wife has a Pixel 3 (identical to mine) and has the same problem, but she doesn’t alternate between WiFi and mobile (cell) networks as frequently. For her the problem is triggered on occasion simply by leaving the WiFi and going on to the mobile network.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

For the record, I believe this problem first happened to us with the last update (that is 5.10.1). Before that we didn’t have any problems.

My wife’s phone is currently unable to use local DNS with the latest version 4 Blokada! I have no idea why as the settings look identical. Anyway don’t derail fixing Blokada 5, I just thought I’d mention it in case similar DNS changes had been made to both at the same time.

Thanks again!

Hello,

Has there been any progress on this problem with Blokada 5 please? I’ve not seen any updates through F-Droid but then again they are always slow to release updates. Do you need me to re-test anything?

BTW: I was able to solve the problem with my wife’s phone with Blokada 4 by copying configuration from mine.

Thank you!

This is still an issue for me on blokada 5.11.1

Anytime I switch between wifi and cell service, my data stops working (when blokada is on) until I deactivate blokada (it also works if I then just re-enable quickly). But this makes it unusable at this point!

Please let me know where I can send my logs to help fix the problem. Thanks!

We’ve had our phones stuck on version 4 after I’d submitted 2 sets of logs. I’m guessing it’s hard to fix as it seemed something that was being investigated early on.

Could a developer please let us know if you’re unable to diagnose or reproduce the problem? I can also get more logs if helpful.

Thank you in advance.

(As an aside I recently tried blokada on a iPad only to find it doesn’t even work with local DNS :frowning: and I can’t use version 4 there)

You mentioned the problem is happening in version 5.11.1. I first saw it on 5.10.1 and didn’t have any problems before that version, after the “network DNS” feature was added.

Given that local DNS is the main reason people aren’t using version 5, I imagine there’s been some change in this area. Is anyone familiar with the code able to look at diffs between 5.10.1 and before please?

For me exactly the same problem. I have a Pixel 3a (one with google, latest software (android 11) and one wihtout google, CalyxOS, also latest version). Because of this problem i removed version 5 months ago, in version 4 the problem exists only when using blokada+ with the VPN. This renders the VPN unusable, because it’s very annoying when you look at the phone and you think “umm … so calm for hours” and then deactivate blokada and hundres of messages arrive …

@PrintableCharacter do to know if there’s been any chance to address this issue yet? Should we be trying version 5 again please?

Unluckily all of this is hardly reproducible to us. You may want to give the newest v5 beta a try but I cannot guarantee you anything as of right now :confused:
If it still doesn’t work, please commence providing us with logs. Maybe we can narrow all that down in the future

@PrintableCharacter Thanks I’ll retest it.

A few of us had asked if you needed more logs some time ago but you must have missed it, so I’ll be sure to mention your name next time.

Hello@blokada.org is always open for issue descriptions including logs :slight_smile:
We’ll have a look at all of them. It might take some time, you may not hear back from us due to the massive amount of information we receive but we surely try to figure things out. We’ll tell you as soon as we find something you could do to help us further :slight_smile:

@PrintableCharacter thanks, but please remember at least two of us had sent logs and you hadn’t responded to say you needed more.
In fact you had suggested we go back to version 4. So we were waiting to see a release note stating this bug was fixed.