No internet access when switching Wi-Fi network

I got the app from (the latest v5.18.0). My device is Sony XZ2, and I’m using the default ROM with Android 10.

My issue is that whenever I changed Wi-Fi network, suddenly I cant access the internet whether its on browser or within apps. I don’t know what makes the Wi-Fi network different since when I deactivated Blokada both Wi-Fi network works just fine. I didn’t change any settings yet cause I’m just starting to try using blokada since literally yesterday.

I haven’t tried anything like tinkering the options cause I really don’t know what works what for, but I did try to search the forum and read some of it yet alas I found no luck. I will attach screenshot from my device along with this post. Please help and thanks in advance.

(Btw I got a notice that new user can only share 1 image so I will just stated that my blokada networks settings goes like this:

Any mobile network: Encrypt DNS, Use DNS: Cloudflare (ON)
Any Wi-Fi network: Encrypt DNS, Use DNS: Cloudflare (ON)

And thats all)

1 Like

Same here. Iphone. USA. App Store. No matter which DNS Server I switch to, it doesn’t seem to work. Same error. Everything’s fine once I switch Blokada off.

Are we talking about one specific WiFi network?
If so: Maybe allowing that specific network to use it’s standard network dns will work. Some routers enforce their dns hence rendering blokadas dns options unusable unless blokada plus is used

Unluckily these issues aren’t even remotely connected due to the OS differences. Please stick to your post

1 Like

Thank you for the time, and for whether its about one specific Wi-Fi network, I’m not sure myself but let me elaborate further.

In the building where I rent in, we have 2 Wi-Fi network (one at the 1st floor, and the other on the 2nd floor). Both are a different Wi-Fi network (not a single Wi-Fi network that was amplified to the 2nd floor) and both used the same internet provider. My issue is that whenever I go to the 1st floor, I can no longer access the internet since my phone would automatically switch to the 1st floor Wi-Fi network. But when I deactivated blokada, I can access the internet just fine using the 1st floor Wi-Fi network.

Yesterday I also tried to switch using mobile data and I’m surprised that I can’t access the internet as well. Then I also tried to use a tethering Wi-Fi network using my friend mobile data and I also can’t access the internet. But when I switched back to the 2nd floor Wi-Fi network, I can acces the internet just fine with blokada.

I know this is weird, but I’m just telling the truth of my first experience using blokada in the last 2 or 3 days. Regarding to allow the specific network use its standard network DNS, can you please tell me how to do that? Because I haven’t change anything on my phone network settings. I did read on other post that I should make the Private DNS (OFF) but since I didn’t change anything, it was already (OFF) to begin with.

Also since other people seems to encounter the same issue on another platform, is it meant to be like this? That blokada can only be used on a network it first set/used up to? I’m terribly sorry but please dont take my word in the wrong way. I really want to just not seeing ads anymore on my phone.

Once again thank you for the time and help to solve my issue. Much appreciated :pray:t3:

It might be set to automatic :smiley: that’s the magic of android. So please double check that :slight_smile:
You may as well want to try a different dns server within blokada.
Additionally there’s this handy-dandy button in the networks tab. Feel free to set your settings per Network using that (im referring to the small text next to the “?”) after you’ve enabled that and gave the necessary permission, you can set every single network to use specific settings

Last but not least: This seems to be an individual issue (Sony might have some something weird), it’s definitely not cross-plattform. But we’ll figure it out regardless :slight_smile:

I have switched the Private DNS to (Automatic) and I also have granted the permission by tapping the text next to the question mark (?) now. But I still cant access the internet when I’m using the 1st floor Wi-Fi network. What did i do wrong and what should i do now? Please see the attached screenshot and thanks again!

Nuuuuuu. :sweat_smile: You’re supposed to set it to “off” :joy:
Open the “1” settings and choose network dns. Let’s see if that works

Oh its working now! I have switched the Private DNS back to (OFF) and its still not working, but not until I changed the DNS within blokada settings to Blokada DNS from thee default Cloudflare. Now I can use the internet again after switching it to my 1st floor Wi-Fi network! Thank you!

But may I ask why is it that the default Cloudflare DNS cause this issue though?

Ask them, not us :stuck_out_tongue: Cloudflare behaves a little… erratic from time to time. We’ve no idea why though. Seems to be individual issues, maybe they blocklisted something :man_shrugging:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.