Blokada for Android doesn't block ads in Chrome

1. Where did you download Blokada from?
The main website blokada . org

2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
Samsung S8+, original ROM, Android 9

3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
I have used Blokada for more than a year without any problems. Since two or three days, ads are no longer blocked in Chrome. Blokada is running, as I can see the host log being updated (only not when using Chrome). Happens both on WiFi and cellular data.

I’m on Blokada version 4.7 and Chrome version 84.0.4147.89.

4. Since when are you facing this issue?
Two or three days.

5. Did you already try to solve the issue somehow? If so: please state what you did.
Followed the generic guide and the one on Chrome. The Asynchronous DNS feature is no longer available, thus I can’t check that one.

I’ve cleared the cache for both apps and rebooted my phone. Chrome is not listed as a whitelisted app.

Does anybody have an idea how to solve this?

1 Like

Hello,
Glad to see that you’ve found our Forum :slight_smile:
Asynchronous DNS can also be called Async DNS Resolver


Have you looked for that as well?

1 Like

Same problem here, on Samsung A70 with Android 10.

After last chrome update there is no more the async dns entry (I tried different searches) and so no way to avoid ads…

If someone finds out a solution, please report here :slight_smile:

Edit: my chrome version is 84.0.4147.89

Yes, this is not available anymore.

1 Like

Maybe I found a workaround. I enabled Adguard dns from blockada, cleared chrome dns cache from chrome://net-internals and it SEEMS that ads are no more showing.

Maybe using a custom dns overrides the now built in async dns feature.

Hope this helps.

1 Like

A permanently enabled async DNS Resolver would be quite a challenge. Report back how long your workaround works

1 Like

Unfortunately, it worked for about an hour, now the ads are back.

I saw that coming miles away
Well… Guess Google gave us something else to play with. We’ll look what can be done. Feel free to share your ideas and thoughts on how one could solve this.

2 Likes

Could you try enabling the alternative DNS response as a DNS option and report back whether or not that did something?

I just tried, it seems to be working so far…

I will let you know if it keeps to work in an hour or two.

Bad news. It worked for some time but stopped working after a while. :frowning:

Google is awesome.

For the people who use chrome regularly, did you disable async dns before the chrome update? I just updated Chrome and Chrome still works for me.

I’m wondering if chrome remembers the settings from previous versions, so as long as you disable async dns before the chrome update you will be fine.

Samsung s10, Android 10

1 Like

Yes, I disabled it in the previous versions as well because without disabling it the ads were shown.

1 Like

I have the same problem since the latest Chrome update. Before the update Blokada worked great without having async DNS disabled and without data saving disabled.

Now I can’t find the option to disable async DNS, too and it doesn’t help to disable data saving.

As of right now we can only recommend ditching chrome. That doesn’t mean that you’ll have to use Firefox or something similar. Most chromium based browsers should do. You can try Brave or Bromite for example.
They’re both based on chromium so you will barely notice a difference.
We will commence looking for other options anyway. If you’ve any other ideas on how to tackle these issues, please let us know here.

4 Likes

Hey everyone,
If you’re feeling lucky you might want to try the following:

In browser, if you’re using Chrome

  • Turn off data saver
  • Turn off QUIC experiment in flags
  • Turn off secure DNS lookup in flags
  • Turn off Async DNS in flags (<C85)
  • Turn off built-in DoH (Set to “Off”, not “Automatic”

Or use other forks, such as Bromite, MacChrome’s Chromium, Ungoogled Chromium.

We’ve received this recommendation from a user and would like to know whether or not it helps you guys

1 Like

Hi everyone,

I’ve found something that worked for me on all chromium based browsers.

Open the normal privacy chrome settings.
Look for “secure DNS”
Make sure to set it to “Use current dns provider”

Let me know whether or not that worked for you as well.

2 Likes

Unable to find any such setting under Chrome Privacy settings. Chrome for Android build 85.0.4183.127

Show me a screenshot of your settings tab