Blokada doesn't block ads in Chrome

If you’re using Google Chrome, you need to disable Data Saver and asynchronous DNS . Google uses those two technologies by default and they interfere with Blokada’s host blocking mechanism.

  1. To disable Data Saver, tap the three vertical dots in Google Chrome, go to Settings, search for “data saver” or “lite mode” and disable it.
    2.1. To disable Async DNS, open the page “chrome://flags” in your browser, search for DNS and disable the Asynchronous DNS feature.
    2.2. On newer versions it can be necessary to disable “Secure DNS” in Chrome’s privacy settings. Make sure to set it to “Use current DNS provider”.
  2. On your device, go to Settings -> Applications -> Chrome -> Storage and clear cache.
  3. Reboot!
3 Likes

Async DNS seems to have been hidden or removed in newer Chrome versions and can interrupt adblocking.

1 Like

This, no longer accesable in Chrome on Android.

A solution to this will be to use our own private DNS, which is something we are working on.

2 Likes

I have no issues on chrome though, Blokada is blocking adds just fine without disabling async dns

Unluckily this does not apply to every user :frowning:

1 Like

Try Bromite

1 Like

Hello everyone, please also check the solution of this post for newer Chrome versions:

1 Like