Chrome 87.0.4280.66 doest block ads

i just updated my chrome , and it didnt block any ads at all even i enable the dns adblocker,tried the flag option and disable dns,both are not working,if i disable my dns i cant open some of the website

Hi there. Try this:

In browser, if you’re using Chrome

  • Turn off data saver
  • Turn off QUIC experiment in flags
  • Turn off secure DNS lookup in flags
  • Turn off Async DNS in flags (<C85)
  • Turn off built-in DoH (Set to “Off”, not “Automatic”

Or

Open the normal privacy chrome settings.
Look for “secure DNS”
Make sure to set it to “Use current dns provider”

If none of the above works for you, you should consider switching to Bromite or Brave at least temporarily.

  • Turn off data saver (never turn it on)
  • Turn off QUIC experiment in flags (done that)
  • Turn off secure DNS lookup in flags (didnt have that in my version)
  • Turn off Async DNS in flags (<C85) (yeah im at c87,cant get the older version)
  • Turn off built-in DoH (Set to “Off”, not “Automatic” (where to find)

i cant set it to curruent dns provider,if i do that i wont able to goto some website