YouTube gets stuck on data saver

  1. Here, 5.19.0 beta channel

  2. P30 Pro, droid 11

  3. It looks like the tunnel isn’t resetting itself consistently so apps either think I’m on metered WiFi or just still on LTE

  4. forever, but now that I’m using my phone for youtube more it’s really pissing me off.

  5. Toggling blokada obviously resets whatever flags are getting stuck and all my apps figure out I’m on WiFi. But this sucks.
    In fact, since my cell reception is a bit questionable in my apt I’ll toggle the VPN have youtube and stuff update and sync things and run at 1080p only to find out I’ve switched cell towers or something and I’m back to metered 240p youtube (and spotify/manga/whatever stops downloading). I don’t think 4.x was as bad at this but then I’ve been on 5.x so long I’ve forgotten.

I know on Huawei you need to turn off WiFi+ (which also sucks for me) to get it to work “properly”. But even then it’s just better at picking up connectivity changes.

Why does the tunnel have 0 problems switching to metered/NotWiFi, but can never figure out how to tag the tunnel back to unlimited?

Previous threads:

It should not do that at all.
Blokada should not get recognised as a metered connection. V5 should already have a fix shipped for that since v5.4
This is very, very weird.
Which blokada version are you using? Are you using blokada+?
Did you try activating the “ping network” feature?

5.19.0 beta channel, no I don’t have blokada+
VPN is connected, always on

Advanced settings are keep alive yes, and ping networks yes.

I would hope when I’m on LTE my apps realize I’m on a metered connection. Like I said my problem is once I’m back on WiFi they don’t figure that out.

So… You want blokada to set your LTE to metered?

As I said in the first post.
I want YouTube app to pick up on the fact I have come back home and get off data saver.

It all works fine without blokada running. With it running I’m stuck on data saver forever.

The interweb search engines says there may be an option in your system settings for “Set VPN connection as metered”. Disable this option if you can find it.

However it may also mean you will never be marked as “metered” while Blokada is on

Found my problem

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.