My Blokada 5 app on Android appears to "stall" the internet connection - and shutting off & restarting the app seems to make it work, but I have to do it several times a day. Any advice on how to fix?

My Blokada 5 app on Android (Android ver. 12, Samsung Galaxy phone & Galaxy tablet) appears to “stall” my internet connection (both wifi & data) when I am using apps that use internet. Shutting off & restarting the app seems to make it work temporarily, but the issue returns within an hr or so, so I have to do it several times a day. I am hoping for a lasting solution.

I downloaded the app (actually uninstalled then redownloaded as part of my troubleshoot attempts) from the official blokada’s “.org” website. This is the Libre, not Plus.

I am using a non-rooted, stock Samsung Galaxy phone (S20), running Android 12, no custom ROM.
Also using a non-rooted, stock Galaxy tablet, running Android 12, no custom ROM. I use the tablet much less than the phone, so I don’t encounter the issue as frequently.

When I am using apps that use internet while Blokada is running - the internet connection sometimes “stalls” (no connectivity, as if I lost either wifi connection or data connection). This happens a few dozen times a day now.

But this only happens to internet-using apps that are not bypassed on Blokada, or only happens to these apps while Blokada is running.

The apps that are bypassed (Youtube Vanced, etc), or all apps while Blokada turned off, run fine with no losses in connectivity.

When I take a look at my Blokada app’s log (2nd button from the left at the bottom), I see that the log entries are not “current” when connectivity goes down. That is, when internet connection is down, the log appears to be also down.

And when I have these internet issues, and I go see what’s going on the log, I don’t see my most recent (unsuccessful) web activity from just now reflected on there, which should be no more than several seconds old.

Instead the most recent web activities logged are from at least 2 minutes or more ago - back when I still had internet connectivity.

While the loss in connectivity feels as if Blokada is blocking a domain name, the domain name itself is not blocked during normal operation - it is greenlisted as default - when internet works, and moreover the domain name doesn’t appear in the log to begin with. It’s as if that web activity never took place.

I think the loss of internet connectivity is related to the log’s absent entries because of how closely their timing matches up.

And these internet outages are occuring with both download & upload traffic.

But as far as my phone is concerned, my connectivity from the hardware side is fine, so it doesn’t try to connect to other wifi because it doesn’t detect poor or no connectivity, nor does it auto-switch from wifi to data, nor does it flag any problems (usually any problems with modem/router/ISP gets flagged).

If I shut off the app, the non-bypassed apps all work fine, like the bypassed apps do. So it leads me to suspect that my app is the issue.

In the meantime, I have been getting around the issue by turning off then restarting the app, or by switching the network DNS setting from one to another - switching from either Blokada DNS to Cloudflare DNS, or Cloudflare DNS to Blokada DNS. It’s not that one DNS over another makes it work, but rather seems to be the switch from the current DNS to a different one - I think it’s having the same effect as restarting the app.

I have also deleted & reinstalled the app, and later on cleared cache & data, and deleted & restarted the VPN profile, etc. to try to “reset” both the app & its various functions. But the recurring abrupt loss in connectivity still persists.

This issue must’ve been going on for the past several weeks (maybe months?) but at rare intervals (maybe a handful or less per day), so it was not a big concern.

But over the past week or so, it has increased considerably to at least a dozen, maybe up to 2 dozen times a day.

So far, my solutions have been to restart the app, switch the DNS from one to another (so far just switching from Blokada DNS to either Cloudflare DNS or Cloudflare: malware-specific DNS, and vice versa), or just bypassing app if it’s not too ad-heavy.

Thank you Blokada team for taking a look at my issue.

1 Like

There might be several reasons why you are experiencing connectivity problems.

Some networks are very restricted. Please try to activate the network DNS option for your network.

  1. In Blokada app, go to Advanced tab → Networks

  2. Tap your network name (you may need to give permissions to Blokada first on that screen, and reconnect to your network)

  3. Tap “Prefer network DNS”

This will make Blokada use your network’s DNS whenever your device is connected to this network. You will see the network icon become green when this configuration is applied.

If this does not help, please check if you are using Blokada Plus (the orange mode - when your location is changed with VPN). If this is the case, then please also select the option “Force Libre mode”, which you can find on the same screen described above.

Let me know if this helped with your connectivity on your network.

1 Like

I have the same problem as OP and browsing through the support forum I can find a lot of posts with the same problem; most of them closed without solution. The solution given here also didn’t help me with the second to last version of blokada5 non plus. So at least the last 2 versions of blokada5 have this issue and there seems to be no solution except keeping 5.21.0 installed because this is the last known working version. You already must have lots of feedback and logfiles so I would ask: what changed after 5.21.0? I would think that investigating the differences to that version would be a good start to finding a solution.

2 Likes

This is a known issue, of which I have been experiencing myself occasionally.
Blokada Devs say they can’t find any issues in Blokada itself, but they looked at my log and found a slight issue with my phone config.
All I can put it down to is that I’ve noticed there’s been a lot of updates from Google (mostly the Google app itself). It could be an issue with Google or with the Android software on your phone.
The majority of manufacturers are using custom Android distributions with their own UI’s.
My Blackview uses Android 11 with DoKe OS with a few security features that the DoKe developers have developed or utilised themselves.
However, things have been relatively stable as of late.

1 Like

Same here. Only thing that worked for me was going back to 5.21.0, which cleared up the issues right away.

2 Likes

This is just a quick update on my own issues, which are the same as these reports in this thread.
I’ve had 2 such incidents today so far, where I have to disable Blokada briefly before a connection could be established. Strange that I’ve had over a week of flawless use and it suddenly starts to play up again.

1 Like

So I tried both - first by enabling “prefer network DNS”, then enabling “force Libre mode”, then enabling both options.

None of them worked over the past few days.

I noticed that the Blokada app (ver 22401.apk) was failing to remain “lock” on to my network.

I had all permissions enabled, had the app connect to my wifi network (wife network name appeared green), then, when the internet connectivity stalled again, I went to check networks under advanced and saw that it had reverted to the general “All Networks” selection.

The app keeps doing this - reverting to the “all Networks” selection instead of my wifi network - with either of the options selected, and with both selected.

I realized an older device that did not have issues - on it I had downloaded the Blokada app off of blokada libre v620.apk.

I transferred the apk to my mobile device, deleted the existing Blokada app downloaded from v22401.apk, and re-downloaded the app off blokada libre v620.apk.

This solved both the connectivity problem, and the failing to remain locked on network selection problem.

I don’t have connectivity issues anymore and my network selection remains locked to my wifi network.

3 Likes

So after about 24h of using the build linked in Still having some issues with Blokada 5 (Android 11) - #10 by DaveyG80 I haven’t had any issues and it never worked that long with the last 2 official builds. I can’t give this feedback in the linked thread because it’s locked and this thread is practically the same issue.

2 Likes

Me neither. So far since updating to 22.4.5 on both my Acer Tab and BV8800, things have been quite steady. There was an issue where there would be a lengthy pause (around 20 secs) before a connection was established. Now it’s down to like 5-8 seconds.

1 Like

Same problem here too. And the last version that worked was 5.21. How do I download older versions?

Edit: found the GutHub page with all the old versions. I went back to Blokada 5 22.3.7 and that seems to be fine.

Edit 2: the latest version also uses a lot of battery and has overall been very unstable!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi,
Are the issues still persisting?

Both my Android phones have been stable so far, but my Acer tab had disconnected the other day.
I’ll keep watch on that one.
Thanks :grin:

Yes the issue is still existing and very annoying. Please fix asap!
Version 22.4.1 / Android 12 / Samsung Galaxy A33

the issued ist still persisting with v22414.

everthings was fine with v2247 !

Fairphone 4, Android 11.
greetings Thomas

Updated to Android 13, same issue. Blokada not yet notified me about available update.
Version 22.4.1 / Android 13 / Samsung Galaxy A33

Please do not post on every thread.
Stick to one.

Still existing, Blokada 5 on Android 12 (pixel 3)

Updated to latest Blokada from website, issue persists.
Version 22.4.14 / Android 13 / Samsung Galaxy A33

Maybe it helps you to fix the issue if I tell you another issue: It not considers network DNS despite I have configured it for my local home network.