Still having some issues with Blokada 5 (Android 11)

Hi.
I’m still having some issues where Blokada 5 Android (installed and updated from Blokada Homepage) will block access to the web until I disable it. Once disabled I can then connect. I then re-activate Blokada and everything is fine afterwards. It’s an intermittent issue where things will be fine for days and then it suddenly prevents me from connecting over my WiFi and mobile data connection.
Once in a while, maybe once or twice a week Blokada will automatically shut itself down as well. I’m pretty sure I’ve covered everything in the phone’s settings with regard to Blokada running in the background and staying active. With the Blackview devices there are a few extra settings to check vs other Android devices.

I have emailed my log to hello@blokada.org and am awaiting a response from support. If any further logs are required, I’ll email them on request.

1 Like

Your log was well received, we are looking into it as we speak?

1 Like

I have exactly the same problem. At first it was normal under Android 12 and on my S21 Ultra, then no connection to the internet was possible unless you briefly switched Blokada off and on again. But then this became more and more frequent. I’m back to 5.21 for now, it’s stable. I hope there is a short-term solution and an update that fixes these errors. Thanks

1 Like

Quick update to say that I have just had another episode of this issue.

1 Like

Not sure if we asked already, but are you also using Blokada Plus when this happens?

1 Like

I also have this issue on Android 12. Im not sure if it’s a RAM issue or not, but sometimes I’ll have a single window open and it decides to turn off, and sometimes won’t restart until I re-open the app. Very frustrating :frowning: I’ve also noticed internet connection issues that have gotten more frequent as of late…

1 Like

This is exactly why I wont update to the latest version

1 Like

For anyone with this issue, please share logs while referring to this topic. It’s helpful to know if you’re using Blokada Plus or not while this happens. If there’s any patterns to when it happens such as after the device has been sleeping for some time or while switching networks or something else.

You might also want to compare with the older version 5.21.0 to see if it seems more stable for you.
This version can be downloaded here

All feedback will help us to pinpoint what the issue is

1 Like

Quick update on my issue:
My Blackview BV8800 has just performed an Android system update to Security Update 1st August 2022, so I’m not sure if this will have any bearing on Blokada’s behaviour. I’ll monitor things and post updates here.

1 Like

I’m not using Plus on any of my devices, but afaik my Android 9 FxTec Pro1 doesn’t suffer with this issue.
My Acer ACTAB1442 (Android 11) is affected by the same Blokada issue.

1 Like

So far, after 2 days since the 1st August 22 Android security update for my BV8800, I haven’t had any further issues to report.
Could there be a possibility that one of the blocklists had an issue?
My Acer ACTAB1442 hasn’t had the 1st August 22 security update yet but it seems the issue is resolved on that too. :thinking:

Good to hear, keep us updated on how stuff progresses

1 Like

Not all is hunky dory as yet. I have another bit of info that may point to the culprit.

I was browsing the web this morning on my Acer tablet and, surprisingly enough, Blokada disconnected from the VPN.
At the time I was setting cookie preferences in a website’s GDPR panel. As soon as I clicked the “Reject all but essential cookies” button I got a notification that Blokada had disconnected from the VPN. :thinking::confused:

If you manage to reproduce the problem on a particular website or through specific steps let us know.
But keep the feedback coming in any case :slight_smile: Thanks!

Had 2 instances today whereby I couldn’t connect to the internet until Blokada was temporarily disabled. This was on my Blackview BV8800.
I’m going to dig deeper into the settings on the phone because I’m beginning to suspect it’s something to do with the power management settings that allow the app to stay active in the background. It’s showing a bit of a pattern where it’s mostly happening when the phone has been idle for quite some time.
It may throw some light on solving the issue for other users. AFAIK I’ve never seen this happen on my FxTec Pro1 running Android 9.

1 Like

Thanks for the thourough feedback as always! We are working on fixes from our side as well.