Update Blokada 5, now stuck on creating VPN profile

I was using Blokada 5, a version from 2022, and recently got notifications that there was an update.
Although I have the philosophy, if its not broken, don’t fix it, and my blokada was working great, I decided to give in on the notifications and update my Blokada 5.

After updating, and opening the app, I got the message that I needed one more step to add a VPN profile. I had to press continue, but no matter how many times I pressed that button, it would just not do anything.

I googled and found many people with the same problem, some even saying that it will not work if you have another VPN profile active. I found an old VPN blokada VPN profile and removed it, but that did not do it for me either. Then I read somewhere that a reboot may fix it.

I rebooted, and lo and behold, it worked. Blokada was activated at boot, so I was happy.
But a day later, same problem. Blokada was disabled, and opening the app prompted me that I needed to create a VPN profile by pressing continue, and continue just doesn’t do anything. No overlay app installed either. I rebooted and it worked again, but a day later, again it stopped same thing.

Annoyed as I was at this point, I tried to troubleshoot it. I stopped blokada app, but even in that state, the app just seemed to still be open. I uninstalled the app, but even after that, it was still open.

Its then that I figured out what happened. There were 2 blokada’s installed at the same time, and they were fighting. I opened the correct blokada but still was stuck with the press continue thingy.

I rebooted my device, and this time, the continue button actually allowed me to add a VPN again.

So to anyone stuck with this, ensure that you have only 1 blokada installed, uninstall all versions and install it again, if unsure, then reboot to get the VPN correctly setup.

/admin, feel free to pin this.


Thanks for sharing this!

1 Like

ا :smiling_face_with_tear:

Just wanted to report that I have started facing this issue on Blokada 5 v23.2.1 on Android from a couple of days as well. I am using Blokada from a long time so naturally a VPN profile was already created. But suddenly the profile was deleted on its own and I got a notification that Blokada has been deactivated. On opening the app, I am stuck with “On next step create a VPN Profile”. It won’t create a VPN profile on its own. On restating the device it starts working again only to get the issue again randomly.

It is likely that you got an update installed that got installed next to another version. Its weird because if you go to your apps, you only see one Blokada icon, but if you go to settings → Apps, you then actually see more than one.

Remove all old ones, and if you are not sure which of them is old or new, just remove all of them, then install the latest v5 again if you removed all.

Finally, reboot your phone, and it should then allow you to create a VPN profile.

Last update was months ago. I just checked Apps section in Settings, only one app is installed.
Like I said, rebooting fixes it.