Unable to update blokada/22.3.8 (android-30 five release armabi-v7a)

First Report 7½ months ago

8" Android 11 tablet 2GB RAM with blokada/22.3.8 (android-30 five release armabi-v7a) with factory ROM.

Going into Blokada Settings →This Device → Details and tapping on “Blokada 5: Official Channel” I get a popup “An update is available” → Download.

Trying to install the now, compared to March, newer release blokada5-android.v5.23.2.1.apk still fails with the same App not installed message.

Previous Blokada updates just worked.

What is going on and why can I more than 7½ months later, still not update to a current 2023 Blokada 5?

1 Like

Can’t you just remove Blokada and install it again? I mean only if you don’t have a lot of customisation which might get lost.

1 Like

That is the exactly the point. I didn’t find an option to export all my customized filters and optional blocklists, and frankly, I am dreading having to set everything up again.
But in the end, I might not have a choice but to start all over again :nauseated_face:

For the phone, also mentioned in the previously linked first report from early March, upgrading finally worked some 3 months or so ago. Therefore I still have/had hopes for a new version that would take care of the upgrade issue on this tablet as well.


I understand the frustration of having to delete Blokada and set up all your customized blocklists.

Are you against subscribing to Blokada 6 for 20$/ year?

That’ll enable you to restore your account whenever something like this happens.


If you haven’t already, could you try grabbing the latest v5 version directly from our website? Sometimes the in-app update mechanism from older versions can be a bit tricky due to structural changes.

As Reda mentioned and if you end up having to start fresh with your settings anyway, I’d highly recommend giving Blokada 6 try. It’s more stable and efficient, plus you won’t have to worry about update issues or loosing settings like this in the future. It’s also lighter on the battery and works across different devices, not just Android.

There’s a free trial, so you can see if it meets your standards without any commitment.

1 Like

That was the next thing I had tried after also clearing Blokada’s cache, but with no different outcome. For obvious reasons I did not clear its storage as well.
In both cases the installer seems to happily process the new package, but then towards the very end behaves like running into some kind of version or access right conflict or such.
When I use the additionally installed APK-Installer instead of Android’s package installer, it briefly flashes “conflict with package already installed” before terminating unsuccessful.

Back on March 7th Reda replied to my initial report:

So I naturally expected a fixed package to become available soon. After a few months it eventually allowed me to update the phone, but Blokada on the tablet unexpectedly still wouldn’t cooperate.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.