Keeps disconnecting on Moto G Power

Hello, I am on a brand new Android Moto G Power and Blokada keeps disconnecting. I have turned on Keep Alive and Always-on VPN but that doesn’t help. Every few hours it seems my phone keeps giving me a notification that the VPN is disconnected. It cycles every second or so. So it looks like it’s trying to connect but the only way I can get it to connect is to click on the notice and Blokada will open and connect. But after maybe a few hours it does the same thing. It’s the only item listed under VPN. I went to Telegram to look for a fix and the only thing I found for other phones but haven’t tried was to excluded Blokada from Battery Optimization. Does anyone know of a fix? I am running the latest version of Blokada downloaded from the website.

2 Likes

Hello,
Excluding Blokada from Battery optimization is crucial for it to work correctly. Consider trying that :slight_smile:
May I ask why you refrained from doing so until now?

2 Likes

Because I just read it and it was a suggestion for another phone but I will try it to see if it corrects the issue.

Hey there:)
welcome to our community! This article might help you with excluding Blokada from battery optimization and any further steps:

1 Like

Did it work? :slight_smile:

Yes it did I was just going to come back to post so if other folks have this problem they can see that removing Blokada from Battery Optimization stopped the notifications and it stays as active VPN. Thank you!

1 Like

Update - turning off battery optimization I thought fixed the issue but it only helped. I am still getting disconnected notices occasionally. In order for it to connect I have to click on the notice, open Blokada and then it reconnects

Oka, then let’s try the next steps:
Please enable Keep alive in Blokadas App settings. Check for one day whether it works. If it doesn’t work refer to this article: Brand specific information.
Try the solutions which are mentioned there for Xiaomi/Huawei, for Samsung/Sony and if none of them helped, please try the solution for Wiko / Infinix:)
If you face problems finding one of them don’t hesitate to ask.

I had the same problem and I tried the absolute everything there was on the internet. All the optimisations but nothing really worked.

I have the solution. Go to notifications in settings, find Blokada, in it’s notification’s settings turn on keep alive.

(If you’re on Android 10) Go home, scroll from top and press and hold on the Blokada notification. Set it to other (so it’s out of the way).

This will 100% fix your problem. Good luck and let us know.

Edit: I forgot to say that I have also “locked” the app in recents.

2 Likes

Hello @Pegasus:D
Awesome, thank you for sharing your solution with us! May I ask which brand your phone is from:)?

1 Like

Hey @c_C !!

No worries, i absolutely love Blokada. I can’t picture my day to day without it so a solution had to be found.
I use Blokada on my OnePlus. It’s on Android 10 :wink:

1 Like

Thank you for this nice feedbakc, I’ll make sure, the devs know about it:D
Okay, if we get more reports on OnePlus we can add that to Xiaomi / Huawei paragraph:), great!

1 Like

What do you mean set it to other? In notifications I found ‘other’ but all I can do is turn it on or off. I thought this disconnecting, connecting issue was fixed but every once in awhile it still has issues connecting and disconnecting. It gets caught in this cycle and then after awhile like 5 minutes or so it finally stops and connects. I still can’t figure out what is causing this.

Is the issue still persistent? Feel free to try the v5 beta