Blokada keeps disconnecting

I’m on Samsung Galaxy a70, blokada was working quite well a few months ago until now, everytime I turn it on it just turns off immediately. I have tried reinstalling the app but it still doesn’t work, I don’t know if this is a bug or not but if it is, please fix it.

Hello and welcome:)!

Could you maybe share a screencap of the issue with us?
Where did you download Blokada from?
Do you mean you tap the button and it doesn’t activate? Or does Blokada randomly stop after a not defined timeframe?
Do you see an active VPN key icon in the status menu at any time?

the screenshot looks normal.
If I tap the button it just deactivates immediately everytime.
I can see the VPN key icon for a second then it just disappears.
I downloaded the app on

1 Like

Okay, could you share the log with us via mail to To share the log, in Blokada go to About Blokada / Share log. Please link this thread.
Could you please check, whether Blokada is listed as VPN in your system VPN settings?
If it is, please enable the ‘Always on VPN’-option (probably hidden behind a gear icon:)). Does that make a difference?
Do you use any other app, that wants to use the VPN api? Like another app for ad blocking, or a real VPN?
You did uninstall Blokada and reinstall it already. Did anything change?
And one last question: What happened before you noticed this frequently happening? Was there a system update? Did you install a new app, maybe?

hey-hey @GET_LOST:)
are you still here with us:)?