Blokada stops to function/work after a while

As a first step, turn on Keep alive in Blokada’s App settings section. In this case, Blokada’s priority will be increased and it can help to stay online; but please note, your system still can effect this behaviour. If you set it, and you still see that Blokada is stopped time after time, check your system’s settings and turn off every battery- and memory-optimisation for Blokada. Unfortunately it is different in every system, therefore please check your phone’s settings or follow the documentation on Don’t Kill My App.

Another option is to enable Always-on VPN. To do it, open your system’s settings, go to Network & Internet, choose Advanced, there VPN. Choose the gear icon next to Blokada, enable Always-on VPN. Also check our brand specific information for specific solutions for your manufacturer.

If you’re still in need of more ideas check out this thread

2 Likes

There are might good news for apps like Blokada.

I read a German article about the battery optimization feature in several smartphones.

If you don’t understand German there’s a Reddit-discussion (on which the article is based on). You can find the discussion and especially the comment about background kills here: https://www.reddit.com/r/androiddev/comments/hk3hrq/were_on_the_android_engineering_team_ask_us/fxg9y4f/

3 Likes

Hello everyone:)

@Guybrush1966 suggested to use an app called Activity Launcher for Android 9 and 10. There you can exclude Blokada from the Duraspeed activity menu. This might help to keep Blokada running in the background as well.
Till now we didn’t get any feedback from people enabling this feature. This either means it works or people using this are loosing their phones and therefore cannot reply anymore;) So it might be worth a shot, but we don’t know yet.
Please comment your experience if you tried this option:)!

1 Like