How to completely / fully de-install Blokada 5?

Hello,

platform: Android

  1. Where did you download Blokada from? Blokada website

  2. Which device do you use? Huawei Mate 10 Pro
    Do you use a custom ROM? No
    Do you know which OS version you are using? EMUI version: 12.0.0

  3. It happens regularly (e.g. twice a day) that ads slip through. My remedy is to install and reinstall Blokada (23.2.1). I have observed that this reinstall is not a “virgin” install but an update of some sort. I can see that several blocklists are selected and I see a long list of exceptions.

My question is how I could completely / fully de-install Blokada 5 without leaving any traces / remnants behind.

  1. Since when are you facing this issue? Since months.

  2. Did you already try to solve the issue somehow? If so: please state what you did. I searched for Blokada remnants after a deinstall but did not find any.

1 Like

Hey,

Thanks for porting, have you tried this adblocking test?

If yes, what score did you get?

Interestingly I score always 3% (total: 15), 5 blocked, and 145 not blocked).
This result is completely independent of the status of the blocking performance of Blokade when using my smartphone.
I ran the test:

  • directly after re-installing Blokada
  • during the use of my phone when ads are blocked to my satisfaction
  • during using my phone when ads sneak through in different apps.

Active blocklists are:

  • OISD
  • Goodbye Ads
  • DuckDuckGo Tracker Ra…
  • URLhaus

Referring to my question about this posting: I hope if I could completely remove all old traces of Blokada and make a totally fresh (virgin) install, I would eliminate the performance problems.

Allow I remember it never ends

Hey @stadlerf ,

Getting a 3% score means that Blokada 5 is misconfigured.

Can you please check on your device settings if your Private DNS is set to “OFF”?

You can do so by going to settings → Connections → Other connection settings → Private DNS.

Just uninstall the App and remove blokada cloud from your Private DNS settings - After that blokada is gone. We hate to see you leave, how should we improve the Service?

I can’t find “other connection settings”
What am I doing wrong?

Interestingly the “devices” tab is completely empty.

After a de-install I checked the DNS settings. There is no Blokada anymore…

I cannot find this one in the list of blocklists.

It seems like you haven’t completed the set-up process yet, can you delete/ reinstall Blokada?

The “Other Connections Settings” is in your device settings and not in Blokada settings.

Please let me know how that works.

Hi, Have you completed the setup?

Once you complete the set-up oof Blokada the VPN profile for Blokad should appear in the VPN section.

@ Reda_Labdaoui
See my initial question in this thread. I suspect that the reminders of earlier installations are somewhat compromised and used to render the re-installed Blokada ineffective after some time. Therefore I asked how to completely remove all traces of Blokada and by this get a new virgin installation. I am still wondering whether this approach could help.

I have found the system setting and have switched Private DNS to Off. That helped partially. It took longer (about 1 day instead of a few hours) until Blokada was tricked and ads started seeping through.

I retested the proposed adblocking test, but the result did not change. There still seems to be a kind of misconfiguration.

Indeed, the VPN profile of Blokada appears after the installation of Blokada. And it is consistently removed after a de-install.

Hey,

Thanks for letting me know, the other thing that might cause this is your DNS configuration inside Blokada.

Please follow these steps and let me know how it goes:

Open Blokada → Go to the advanced tab → Networks → Click on “All Networks” → Click on “Use DNS: …” → Select Google’s DNS

Please let me know if that helps.

I now selected “Google”, the previous setting was “Cloudflare”.
I also see that Blokada is used in plus mode.

First impression: positive. I’ll keep you posted.

1 Like

Thanks @stadlerf , looking forward to hearing how it goes!

I tried

  • Google
  • Blokada DNS
  • AhaDNS (Netherlands) {as I live there}

The improvement with using Google and Blokada DNS compared to the old setting “cloudflare” is that I only need to reinstall Blokada once per day (instead of 2-3 times).
AhaDNS (Netherlands) failed almost immediately.

(I still wonder whether a complete wipe of Blokada and a virgin reinstall would change the situation.)

In the meantime I tried to go back to Cloudflare. The behaviour stays the same. It seems that the DNS provider does not have impact on the behaviour / performance of blokada.

The problem remains unsolved for now.

Thanks for reporting this! Do you notice any change of behavior if you change from Wi-fi to Mobile Data?

I regularly stay at home for a day or two. So the observed behaviour happens in a WiFi only situation.

I hope I understood your question correctly.

It makes sense, certain Wi-fi networks are a bit restricted and don’t allow the use of third-party DNS services. Please follow these steps to resolve this:

  1. In Blokada app, go to Advanced tab → Networks

  2. Tap your network name (you may need to give permissions to Blokada first on that screen, and reconnect to your network)

  3. Tap “Prefer network DNS”

This will make Blokada use your network’s DNS whenever your device is connected to this network. You will see the network icon become green when this configuration is applied.