Blokada 5 no longer blocking ads on Android 12

Hello,

I’m having issues with Blokada 5 and it’s reached a point where I registered on your forum to discuss the issue.

I’m using Huawei P20 Pro with EMUI v12.0.0.225 with Blokada 5 v 23.2.1. Blokada 5 was downloaded from your site and not from Google Play store. I have all available block lists enabled.

So, first issue. Blokada, despite I set up local VPN, can’t remain active. Lock logo is in the notification area, but it looks like the app is active, while the VPN is being turned off. When I manually disable and enable ads blocking, it works up to 24 hours, then I need to repeat these steps. This is ongoing for years, practically from the start. And yes, have disabled battery optimization for Blokada.

Second issue. Blokada has stopped working completely about three months ago. So about two months ago I tried the subscription with VPN in Italy and it again worked well. But then the subscription ended and all the ads are here again. No matter what I do, ads are being shown.

Answers to questionnaire:

  1. your website
  2. Huawei P20 Pro, EMUI v12.0.0.225
  3. see above. The issue happens on mobile data or wifi, doesn’t matter the connection
  4. from long time ago, can’t recall the version it started
  5. subscription, disabling and enabling all the lists, disabling the VPN and enabling it, deleting the VPN and re-creating it, allowed the app to stay active (disabled battery optimization)

I would like to provide more information, but don’t know which. Can you please let me know which info you need to resolve this issue?

Hi @depalmo ,

Thanks for posting, Blokada not blocking ads might be due to multiple reasons, but to identify if it’s just a setup issue, can you please share your adblocking score?

If your score is above 70%, that means we just need to work on your blocklist selection.

HI @Reda_Labdaoui ,

Thank you for the link. The score on that page shows as 97%, which is rather surprising!

I didn’t browse the web a lot for last few days, but the local news section, which was without any (and I repeat, any) ad, it’s now cluttered with ads. For example this page: Dnevi pred nami ne bodo nič kaj prijetni: Arso napoveduje nove pošiljke ploh in neviht - Metropolitan.si

And to repeat, the “blocklist selection”. I selected all. So they should all be enabled.

Thanks for your reply @depalmo , unfortunately, mobile adblocking is never 100% accurate, a score of 97% means that Blokada is blocking most of the ads and trackers that might come up on mobile apps and websites.

I suggest you check if the entry on that page is blocked or allowed.

You can do so by going to the activity tab → clicking on the search toggle in the top right → search for metropolitan.si → if it’s showing in green (allowed) → Click on the entry and add to blocked.

The problem with doing that is that I will block entire domain, so won’t do that.

I also searched for an option to add a custom entry, but found that Blokada 5 does not support that anymore. Can you please confirm if that’s correct?

Since we won’t resolve first issue, let’s try to focus on second issue, where Blokada stops working. I can’t find the article I followed, but can confirm that:

  • I have locked the app in recent apps view
  • I have tried with always on VPN and keep alive
  • have disabled all battery optimizations for Blokada 5

But the app still keeps getting disabled. Some times the app does appear active, but the activity is not updated. Despite I am browsing the internet, it shows activity from few hours ago and at that time it also shows ads. If I disable and enable the blocking (big button on home screen), it again starts to work. It looks to me like the app is kept in background and running, but the VPN connection that it makes is killed.

I’ve been troubleshooting the continual deactivations of version 4 on my Samsung S22 phone that started about a month or two ago. The same thing is happening with version 5 on my tablet.

I think I’ve narrowed the cause down to the possibility that Norton 360, which I use, has had a change in its “Auto VPN” behavior. That feature automatically turns on a Norton VPN on when it identifies that the device is connected to a public or unsecured Wi-Fi network. It’s supposed to turn off the VPN when the unsecure Wi-Fi is disconnected. Instead, it seems to now turn off ALL VPNs, including deactivating Blokada. Norton 360 also seems to periodically check to make sure that the VPN is turned off, also resulting in Blokada being deactivated. Previously, Norton 360 turned on and off only it’s own Norton VPN.

I’ve been able to keep Blokada activated by setting Always-on VPN (“Stay connected to this VPN at all times”) under More connection settings. But this setting has its own complications by preventing the use of other VPNs without navigating to the setting and turning it off.

I haven’t seen any other reference yet to Norton 360 being involved in the issue, but I do have two devices affected as described.

Yes, custom entries are only supported on Blokada 6 or through the dashboard. If you’re a Plus subscriber you can use your dashboard app.blokada.org.

This is a common issue on Blokada 5, Blokada is turned off in the background usually because of the battery saving settings or because it’s consuming a lot of memory ( in case you’re using too many blocklists).

Here are a few fixes I would recommend:

  • Minimize the number of blocklists to 2-3 lists.
  • Go to the advanced tab → networks → click on “all networks” → pick “Google DNS”

Let me know if this helps.

Ah, that could be the reason, since I have all the block lists enabled. Apparently I will have to live with it, thank you for clearing that one up.