Blokada not bloking anything on my device. I have downloaded and installed latest beta and all the applications showing ads. I have enabled all the filters in the list

Blokada for Android doesn’t block ads in my device

  1. Downloaded from blokada website
  2. I am using Redmi note 8 pro on MIUI12 India
  3. I am getting ads in all my apps in a the network.
  4. The issue is occured only after installung latest version (Beta)
  5. Enabled all the filters you have provided. But the traffic list showing every request is under green color and ads are visible in apps. Traffic list not showing anything under red.

Hi,
Make sure to disable Private DNS in your system settings. It might be set to automatic which will not work.

1 Like

Not working. Could you please suggest me how to disable this. I have disabled htts DNS settings.

The issue haplens when i enable block lists from block list. If I disable this, blokada will block some of the ads.

1 Like

You’ll have to look through your system settings application. You cannot find this within Blokada

Since yesterday I have the same problem on my iPad and my iPhone. Before everything worked fine. Looks like there is something wrong with Blokada. I can’t activate no blocking lists. It keeps showing the error message.

I have the same problem with the energized lists and blokada 4.8.6 (f-droid). The URL is https://blokada.org/mirror/v5/energized/blu/hosts.txt which doesn’t work since the redesign.
You could use other host lists that are hosted elsewhere.

Already disabled. Not working…

Okay.
Now except blokada from battery “optimization” and grant it always on vpn permission since it’s literally not running anymore in this screenshot if I see that correctly

Since the problem is also happening on iOS this seems to be another problem. Yesterday it worked on all my devices. Today i can’t download any blocking list. There is no battery optimization in iOS like on Android.

Please stick to your post. Do not hijack posts of other devices. They most likely aren’t even remotely related

Okay! This is the exact same error message. Just saying…

No, I have excluded from blokada from battery optimization and the always on vpn is enabled.

no luck…

Try choosing blocklists once again

I also encountered this on my MIUI 12 device. On Blokada 5. What I did was follow the guide, and what worked for me is I:

  • Save account number for account recovery.
  • Turned-off blokada VPN.
  • Went to app settings of blokada, and clear all data.
  • Set it to auto-start, allowed storage permission.
  • Opened Blokada, do not turn it on yet, go to Blocklist, enable filters that you like.
  • Restore your account.
  • Finally turn on Blokada’s VPN.
  • Check on canyoublockit or other similar sites.

I have the same problem. Blokada in version 5.4 does not block advertising since a few days. I was wondering if I did something different. The only thing I did: I tried the DNS server of Blokada. Since then the app does not block advertising with other DNS servers. When I switch back to Blokada DNS everything works again. I think version 5.4 has a problem with the DNS? Especially the DNS of Blokada?

Well
This is an entirely different problem though. Not remotely connected to this one discussed here.
Please create your own support post :slight_smile:

Still not working.

I can’t uninstall blokada. After deleting all blokada files and uninstalling the app I’m still greeted with upgraded and my settings? How is that possible?

There’s an option called “Use cloud backup” under “This device”

I know this option. I disabled it before uninstalling. After installing it’s enabled by default and my data is restored. Where does blokada store my ID? I didn’t connect my Google Account with blokada. How can I change my Account ID?

That is because you don’t need to.
It’s a feature of newer android versions. They’ll just backup your settings by default.