Some apps/ads seem to bypass Blockada 5 Android


1… Where did you download Blokada from?: Blokada website, version
2.1 Which device do you use? Huawei Mate 10 Pro, Model BLA-l29
2.2 Do you use a custom ROM? No
2.3 Do you know which OS version you are using? Huawei EMUI version 12.0.0 (according to a Google search this is based on Android 10)
3. Please explain the issue as detailed as possible.
I observe (in the meantime daily) that ads are appearing in different apps.
To work around these issues I de-install and re-install the app (sometimes three times a day). After re-installation, everything works as expected (and what I had experienced in the past for a number of years).
A: I re-install Blokada
B: I disable notifications
C: Several settings survive the re-install (like blocklists used, blocked and allowed exceptions)
D: I use the phone by using several apps
E: After a while (I was not able to reproduce time or (related) app usage) apps start to appear again
F: The orientation of the VPN key in the status line remained unchanged
G: The activity log does not show all internet accesses anymore. Sometimes no activity has been logged for hours, despite the fact that I was using the phone.
F: go back to A:

  1. Since when are you facing this issue? several months
  2. Did you already try to solve the issue somehow? If so: please state what you did. de- and re-installeing

Well, obviously I would like to get back the full, undisturbed functionality.
which additional information would you need for analysis (like (additionally generated) logs, and so on?


Please try to empty the cache and reboot your device. It should solve this issue.

1 Like

Emptying the cache and rebooting did not solve the problem.

As I described I observe these problems for months, the device had been rebooted several times since.

Additional observations, done before the reboot this morning:
In the situation that ads are not blocked, hardly any traffic can be seen in the activity log. I was using a news app (via clicking on a notification) and nothing (neither any transfer from their website nor the communication with ad servers) was logged.

Thanks for the explanation, have you tried an adblocking score? What score are you getting?

Also I’m wondering if you have by any chance bypassed some entries that could allow the ads to come up?

The reinstall seems not to be virgin. I see in the activity log that it continues a list of activities dating back to 9-25-2021 with the new activities after the reinstall. Also, the blocklists are those I chose in the past and both types of exceptions are populated, most likely with the status of 9-25-2021
Once I tried to remove all allowed exceptions to test whether this would solve the problem, but it did not.

Right now Bockada is working, so I tried This confirmed that Blokada does its job (until the s***t hits the fan).

I’ll re-try that when I’ll observe that Bloackda stopped working properly.

In the meantime Blokada did not stop those ads anymore and, as proposed, I checked again.

Interestingly all ads at are still stopped!

What else could help to understand the situation?

ok so what kind of ads are you seeing exactly? can you share an example?

Also please try this adblocking test: Test Ad Block - Toolz

Having a score of below 70% means that something is misconfigured in your settings and we’ll need to look into it

It gets even more funny.
Blokada is working right now.
If I use this forum from within the Blokada app and click on the toolz link I get a score of 4%.
If I use this forum from within the Chrome browser and click on the toolz link I get a score of 93%. See added screenshot.

As soon as I’ll see ads again I’ll update some screenshots.

Just a thought: what is the procedure for a “virgin” reinstall?
I wonder whether the kind of “rollback” reinstall which is happening might impact the behaviour…

hey, I had a similar issue! maybe it’s a problem with your blocklist? I only used OISD before, and I think it’s no longer enough to get rid of all ads. Blokada comes with other options, you can find them in the app under the “Advanced” tab. ads are getting smarter, so we gotta use more restrictive blocklists. let me know if it helps!

As Blokada works properly (as long as it’s working) the blocklist could not be the problem.
I played with the advanced settings but did not find a remedy…

As requested here some screenshots of ads which blokada didn’t block.

Please also have a look to the screenshot of the activity list before taking the screenshot I used apps of:
The guardian
NY times

What struck me as well is that in such situations the app stalls sometimes. I observe a long reaction time before I can scroll activity list again.

All right, please send us your log at and we’ll take a closer look

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.