Blokada is not blocking any ads device-wide

Hi Blokada team and users.

As is not uncommon, Blokada is not blocking any ads anywhere ever on my devices (plural, though mostly my mobile phone).

This has been a persistent problem for me in every release of Blokada after 5.5.0, and as such I’ve generally stuck to using 5.5.0 because at least it works. Well, it used to. Since updating to 5.10.1, I can’t get 5.5.0 to work again even after removing previous versions.

I’m somewhat tired of being unable to update the app due to this. I’ve done everything I can think of to try get it to actually block ads and it never actually does block the ads. It doesn’t even detect that I am doing anything at all.

As is usual when I experience tech issues, I go through basic troubleshooting steps. These do include checking I’ve actually got blocklists activated, that I’ve turned ad-blocking on, and restarting the device itself just to be sure. Despite all of these steps, and many others including checking app permissions, ad-blocking does not work in any capacity.

Useful info that techies and developers generally need to help diagnose problems in apps:

Device: Huawei P20 Lite
OS: Android 9

Blokada version string: blokada/5.10.1 android-28 full beta amd64-v8a HUAWEI HWANE touch api compatible
Source: Blokada in-app update.

  • Is ad-blocking enabled? Yes.
  • Have I tried a device restart? Yes.
  • Have I checked app permissions? Yes.
  • Are any apps bypassed in Blokada’s settings? No.
  • Are ads being blocked? No.
  • Are app network requests being logged? No.

I’ve previously tried to fix this issue by using older versions of the app with mixed success. As of today, even v5.5.0 (which used to work) does not work. This has been an issue since v5.6.0 was released.

If anyone could provide me with some useful info or actionable advice, I’d be very appreciative. I’d rather not go back to an outdated version of Blokada.

Not sure if this of any use been over 3 years since using android. In settings,security, device administrators see if Blokada is even there usually find my device ,Google pay ,screen lock service are there Good luck

Apologies for not responding sooner. However, as you’d expected, the advice didn’t offer me any change. Android does not have these options anymore.

Unrelated, the Blokada 5.11.0 update has changed absolutely nothing. This issue is frustrating me and currently it’s feeling like we don’t care (since only one person offered advice).

So what’s in the activity tab? Is it all green or are there some reds?

Some are red, so the actual ad-blocking seems to be somewhat functional.

The vast majority of network requests from varying apps are not being captured or intercepted by Blokada. Only background requests like those to update widgets or fetch notifications from a server. If I load a website on a browser, nothing happens in the activity tab at all. But if I hit refresh on the widget, I see something then.

The most recent version of Blokada that functions for me is 5.2.0. Any later version does not work as it fails to capture the vast majority of network requests.

Note: I mistyped the version number in OP as well, as that was intended to be 5.2.0 too. The same problem occurs on my Samsung tablet.

Have you tried version 4 before? It looks a little different and works slightly differently but is still supported.
I have a Huawei tablet running v4 and not had any big problems with the blocking, not upgraded to v5 just yet so can’t say if there’s problems with it on this device.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.