Blokada 5.6 doesn't block ads

As usual, yesterday I updated Blokada from 5.5 to 5.6 and, as usual ads filtering has stopped.
I followed the procedure indicated by GreggH in this old post, however it doesn’t work. Still ads are not blocked.
I don’t understand why, every each update, block ads goes broken. Every time the same problem :frowning:. If someone has some tip, let me know. Cheers :slight_smile:

Please give as precise specs and descriptions of the issues as possible

Doesn’t it block ads with just Chrome or every app?
For me the problem is only with Chrome:

  • v.5.2.1 works with every dns
  • v.5.3.0 does not work with any dns
  • v.5.4.0 and v.5.5.0 only work with “Blokada DNS”
  • v.5.6.0 does not work with any dns

So if I need to use Chrome, the solution is Blokada v.5.2.1 or v.5.5.0.
My system is always the same (Huawei P Smart 2018 stock Androdi 9) and Chrome is always the same (latest version). But each version of Blokada is a surprise.9

1 Like

Have you rebooted after updating? You may need to grant VPN permission again.

Again @Stefano
You’re the only person who seems to be facing this issue.
Blokada is working just fine for thousands of users. Please do not expect others to face your exact issues and start with general advice first.
Feel free to reset your device and see if that works for you

1 Like

I don’t know why I’m the only one. However I switched back to 4.9.0 and I’ll stay with it. Because v 5 has something that doesn’t work in my opinion. I have Android 9 on Huawei Mate 10 Pro with EMUI 9.1. I followed indication of old post I mentioned and it does not work. I can tell you only that it happens at every update. However, consider this post closed, because maybe it’s just a particular case of my phone (even if I think every Huawei with EMUI 9.1 should probably have this problem) so I will stay with v. 4 for now. Sorry for the inconvenience.

Please notice that the reply I sent last was directed at Stefano, not at you.
We’ll continue looking into the issue you’re facing. Please provide logs if possible

Same here

Just chiming in to say I’ve got a similar issue here.
Motorolla Moto 4x
Android 9

Downgrade to a 4.x version or 5.1.0, and everything starts to work again.

I’ve tried clearing cache, clearing storage, rebooting the phone in between installs, reenabling permissions, completely uninstalling and reinstalling the app. I just can’t get 5.6.0 to work at all. Still experimenting to find out what is the latest version that works on my phone is.

v5.5.0 seems to work without issue for me.

Something broke again and 5.6 does not even work with Blokada DNS or any other then I install 5.5 it works again.
Permission for vpn was re added.
Android 9
MIUI 10.3.4

I sent my log to I hope that this could help into solving the issue.

1 Like

same for me. doesn’t work

I think if you clean cache of the app will be enough to solve the problem. Just try it and see if its work.

Thank you. That can resolve a lot of issues with a lot of different apps, for sure. I’m not sure about the OP, but that didn’t resolve the issue for me on this one, though.

Things I’ve tried:
-Rebooting phone after install.
-Clearing app cache.
-Clearing app storage.
-Ensuring permissions are enabled.
-Uninstalling app entirely, rebooting, reinstalling app.
-Downgrading to a previous version that does work, then upgrading to this version and checking that all the settings are the same.
-Ensuring there are no apps or settings that are changing anything having to do with networking or killing apps/background processes.

Motorola Moto X4
Google Fi
Android 9 with latest security updates available on this device.
Stock; not jailbroken, CFW, etc
Blokada v5.5.0 working without issue.

I’m not too worried about it, for me anyway. I found a previous version that works, so thats all I’m looking for. I’m more just posting this in case anyone finds it helpful.

As far as I’m concerned, the best adblocker is one you never have to think about or touch, and you sorta forget its even there until you see it in your app list and wish you could give it a high-five.

1 Like

I entirely agreed with you. I am glad that you resolve that issue. Congrats.

Folks, we need logs. As many as possible regarding this issue :stuck_out_tongue:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.