Blokade stopped working completely

I have a generic Android tablet using android 10 with Blokada paid. I just booted it for today and up popped a message saying version 6 was ready. I started following the prompts and when it got to play store it gave me a message saying it wasn’t compatible with my tablet. I went to the Blokada site and clicked on Blokada 6 to upgrade. All I got was a white screen with just the Blokada shield in the center of it. I deleted Blokada and tried again with the same result. I deleted it again and reinstalled version 5 and again received the shield. I deleted it and did a restart and still just got the shield. I deleted one last time and turned off the tablet completely for 10 minutes before reinstalling. Still no luck.


Have you tried to install Blokada 6 directly from Google Play store?

As I said in my post, when I go to the play store it says that the app is not compatible with my tablet and does not show the install button. Unfortunately it doesnt give back version 5 .

1 Like

it seems that blokada 6 is a subscription based app now, which is a shame. We liked it as it was free, but i guess you can still use the version 5 for free but it’ll maybe put a message where it say, subscription has ended, please renew (stuff like this).

As i said it will no longer let me reinstall version 5.

Blokada 6 requires Android 9 or higher, and is available on Play Store.

If you have older device, you may install Blokada 5 from our website:

I’m not sure anybody is reading what I posted. Lol. As I keep saying, play store says my tablet is not compatable and I cant get 5 or 6 to work from the site and my tablet is android 10. All I get is a white screen with a little blokada screen in the center of it. I’m a bit unhappy at paying for something I haven’t had for a week and I cant get it to work.

I am not sure tbh why Blokada 5 or 6 won’t work on your device if it’s an Android 10, so if I understand correctly the app installs correctly but doesn’t open?

Exactly! It was working fine until it notified me about version 6. As soon as I clicked on it it took me to the play store where it said it wasn’t compatible with the my tablet. I went back and downloaded 6 from the Blokada site and that’s where everything went wrong.

Please try this: go to settings and search for Download Manager. Go to storage and cache and clear both. Restart your device and see if this solves your problem. You can also try the same with Play store app in settings. Afterwards try to download blokada 5 from website.

1 Like

Thank you, thank you, thank you! That worked! I didn’t even try from the Play Store. I just downloaded 5 from the site after deleting the things you said to do and restarting.

Glad to help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.