Blokada+ slows internet speeds when VPN is on

Running version 5.1 on a Pixel 4a with Android 11. Downloaded from this site.

I’ve been using the VPN for a month now, but i just noticed the other day that it’s significantly slowing down my WiFi connection on 2 different devices (and LTE to a lesser degree). I’m not sure if it’s been happening and i’m just now noticing, or it’s been going on.

If it’s a new problem, I suspect it might have something to do with my subscription expiring Sunday 9/27 and my renewing it.

I’ve been using the Cloudflare DNS, but I’ve also used AdGuard for a bit and just now tried Google and a couple others. When I run a speedtest with the VPN on, I get about 25-54Mbps down and 5-10Mbps up. When I run a test with it off, i get speeds of 115-145Mbps down. Same results on any DNS, and the speeds are better as soon as I disable the VPN (but still leave the ad block on).

I also have my laptop set up–i think it’s on the Blokada Beta DNS–and I’m having the same issues. It’s a Dell running Windows 10 64 bit.

I also uninstalled and reinstalled the app and I’m still having the same issue. It cuts my speeds roughly in half for any DNS I use.

Anyone got any ideas? I emailed my logs to the inbox on Sunday.

1 Like

Someone help please :frowning:


Ok let’s try to debug this.

  1. Install 5.2 from the website.
  2. Make sure you have “Use Blokada DNS in Plus mode” enabled
  3. Make a speedtest (with any speedtest app), send a screenshot
  4. Share log to
  5. Turn off Blokada, make the speed test with the same app.


It’s known that Android may have less than optimal speeds when using a custom VPN implementation such as with the WireGuard protocol. However when you also get the same issue on your laptop there might be something else causing issues.

If we focus on using the laptop for testing, did you also try a couple of different gateways to see if it improves?
If not, could you let me know which gateway is closest to you?

To figure out if there is an issue with the routes from your ISP to our gateway, you will need to provide a traceroute (make sure your VPN is turned off while doing so):

Then make a traceroute for the gateway that you have selected and send it to me in private, see the IP of each gateway below:

Location IP
Los Angeles
New York

Hi thanks so much for responding!

I just emailed logs and screenshots from the speed tests. I sent one set on WiFi and one set on LTE.

I’ve uploaded the screenshots here, too.

1 Like

Hi there and thanks for responding!

I have not tried different gateways or done a lot of troubleshooting on my laptop, but I’m closest to New York.

I should also note that this problem persists on my work WiFi network as well. I set up the VPN on my laptop for the 2nd time (after my subscription ended) on that network, though. I’m not sure if that has anything to do with it.

I’ll run a some speed I tests and trace test when I get to work and send you the results. How do I send them privately?

Thanks for your help!

1 Like

Great, do you also have noticeably better speeds at work when running speed tests without Blokada?

To send a message in private, select my avatar and choose Message

1 Like

This looks to me like you’re not on Blokada Plus and are still seeing ~22Mbit/s? As carrier is detected as Verizon. I’d also like to point out that about 25MBit/s can stream 4k video and 5MBit/s for HD. Also your ping time (responsiveness) is within expected ranges. Even though you have 100MBit/s while on WiFi, this might be good enough for your phone usage?

This one however may be the Android limitations while you’re on a WiFi capable of 100Mbit/s.

Looking forward to the laptop tests!

1 Like

I just got to work and ran speed tests on my work WiFi from my phone.

This one is with Blokada+ enabled:

This one is with Blokada+ disabled:

As for the previously posted screenshots on LTE, the first one (27.6Mbps) is with Blokada+ enabled. The 2nd one (46.2Mbps) is with it disabled. Is it not supposed to detect Verizon with Blokada+ on? Here’s a couple more on LTE, this time from work:



Also, yes 22-25Mbps should be okay while on LTE, it’s just noticeably slower and I wasn’t sure if that was normal or not. If we’re trading off speed for privacy, that’s fine.

Another note on my laptop at work: I cannot connect to the network with WireGuard activated. When I connect to the network with it deactivated I can connect and browse, but when I activate WireGuard again, the WiFi status says “no internet, secured.”

When I deactivate again, the connection immediately returns. This could be because I set it up wrong the 2nd time around, so I’ll delete and re-add the device and try again. I did not try this on my WiFi at home, though.

Please make sure to close the speedtest app in between tests because it might have cached a test server that is closer or inside Verizon networks instead of what is closest to the gateway location. Verizon should not show up.

Since it seems to work on your phone while on the same WiFi, I would guess there’s a WireGuard or Windows specific issue. Try completely disabling the WireGuard app and the network interface and possibly even a reboot, then try again. If it still doesn’t work, you may also try to download a new configuration from

I tried closing the speed test app and clearing the cache from Android settings and it still reads Verizon with Blokada+ enabled:

I’ll also try uninstalling WireGuard from my laptop and setting up a new device. I should also note I have not confirmed this same behavior with my laptop on my WiFi at home yet.

Lastly, you said earlier that suboptimal speeds on Android are expected with Blokada+ enabled? Are the speed differences I posted considered suboptimal or do they indicate something’s wrong somewhere?

Thanks again for your help on this!

I reinstalled WireGuard, deleted the previous laptop setup in Blokada then set it up as a new device, selecting New York as my gateway.

The connection works now and I can browse the internet with VPN activated, but I’m still seeing significant differences in speed.



I’m also getting ready to send you the traceroute. Should I send one from like it says in your resource, or send from the New York gateway’s IP?

Thanks for the updates.

The Verizon status is strange, but speed wise I think it’s OK. I’ve seen similar numbers on other Android devices in the same network where I got ~500MBit/s on my iPhone (out of ~800MBit/s).

I’d say getting 100MBit/s on your laptop is also an OK speed, there are many factors which may affect the speed and you cannot expect having the same speed as with the VPN deactivated. You might want to try manually selecting that “Pilot New York” speed test server while VPN is deactivated to get a more fair comparison.

Thanks for the troubleshooting!

1 Like

Okay great thanks for the information! So it sounds like I should expect these speeds moving forward with VPN enabled? They’re not bad by any means; I was just concerned by the large difference in speeds.

HOWEVER, I’ve just now run into another issue…

I tried deleting my phone from my devices list and reinstalling v5.2 on my phone (which it was working fine on a few minutes ago), and now I’m getting no internet access at all on LTE or WiFi with Blokada+ enabled. I don’t think I did anything differently, but here we are.

Sorry to be such a bother.

Try switching the app off. Then select a different Plus location and back again to New York.

Deleting devices may not be automatically detected by the device that got deleted.

1 Like

That solved that issue–thank you! So I guess that’s everything then. I really appreciate your help!

1 Like

Thanks for your follow up. We may provide more alternatives to WireGuard in the future, for users who prioritize speed a little bit more than privacy.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.