Blokada Cloud on Android: Cannot connect to Private DNS


I have two Android devices (phone and tablet) which have been “running” Blokada Cloud for months, but they both stopped working on WiFi recently with the error: “Cannot connect to -*”. On mobile data (on the phone), it does work. I have an Asus ZenWifi XT8 Mesh WiFi setup. How can I troubleshoot this? I have gone through all DNS settings on my WiFi router but to no avail…

Thank you.

I also continue to receive Android notification Private dns server cannot be accessed

If you gentlemen are using Chrome on Android, in Settings… Privacy and Security, Private DNS should be set off.

In my case, the error does not occur in Chrome, but in Android itself…
See the screenshot:

Same advice still applies… turn off DNS (option on right of error notification or top option onmain dialog.

1 Like

That seems to work, thank you. However, it used to work until a few weeks (?) ago.

I don’t know why it worked previously, because Private DNS off has long been necessary for Blokada to function.

How can I block ads in apps other than Chrome with Private DNS disabled? I am seeing ads now in apps where I wasn’t seeing any previously. Sorry about my confusion. Thank you.

Which DNS do you have enabled in Blokada? I tried several and found Cloudflare (encrypted) to be best for me, but you have to find one that works for you.
Additionaly, which block list(s) do you have enabled. Again, I had to try various lists and/or multiple lists to find what was most effective for me.
You may have to manually block some web addresses no matter how good your other settings are. I found it effective, after an ad I don’t want appears, I go to the Activity list to find the offending address, and block it there
There is no simple, single answer to blocking ads. Some trial and error is necessary to find the best settings for you.

Since the topic is about Blokada Cloud, Private DNS is expected to be configured or Blokada Cloud won’t function.
The advice to disable Private DNS is only relevant for Blokada v5 and older.
It’s a bit confusing, I know :slight_smile:

The latest update on Google Play might resolve the error, we’re still waiting for Google to approve this.
To be able to verify if this is a known issue, please send the logs while referring to this topic.

Logs sent from my Oppo Find X2 Pro. Thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Post opened for further feedback