Blokada Cloud not working anymore

I know it’s a beta, just wanted to know if it’s just me or not.

Could not find a “status” on the cloud portal. But since yesterday night 30.9 my devices say there is no internet connexion until I disable private DNS.

Anyone else experiencing that?

We’ve had a few of these reports and are investigating.

The service itself is working fine but was experiencing a brief outage for a few minutes, there seems to be something with Android in particular with handling this reconnection attempts.

Weirdly enough blokadadns doesn’t allow any internet access anymore. Similar to the problem I have with blokada Cloud (see my other post)

I tried with cloudflare, internet works but Netflix us doesn’t. (it never has only blokada DNS used to work for me)

Also on my android device since yesterday night there is no internet connection when I enable the private dns with Blokada Cloud address.
But, on the same android device the Wireguard vpn generated with the Blokada Cloud dns configuration works correctly.
Moreover on my MaCOS MacBook Pro both the Blokada Cloud profile and the Wireguard vpn generated with the Blokada Cloud dns configuration work correctly.

And regarding the old Blokada DNS (not Blokada Cloud) there has been no updates here recently.
Making me think there’s something else at play. I also verified that it’s up and running, replying to queries just fine.

Please make sure the private dns is “off” before going back to Blokada v5. Also disable any other VPN apps you have running. Maybe try an older version of Blokada v5 if you’re still having issues to see if there’s a difference.

Thanks for verifying this is an Android (or DoT) specific issue

So it turns out that Android private dns (DoT) has its own certificate authority handling, where they have the old root certificate for Let’s encrypt which has expired.
Android no longer trusts certificates issued by Let’s encrypt for private dns, but it does trust them for anything else such as browsing the web.

This is an unfortunate timing, I’ll continue exploring workarounds for this

The issue has been resolved, Android should now work fine again.
We had to replace the certificate with a new issuer


Ok, thnx. I can confirm it works again :+1:

1 Like

Ok thanks I’ll try cloud again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.