Blokada cloud private dns not working on wifi

so, now blokada stopped working on my android when im using wifi.
when on 4/5g all works well, when switching to wifi the private dns can’t connect. so no internet connection at all.

I’m using plus, blokada cloud

Has this to do with the wifi network or the blokada cloud service ?
This is driving me crazy. Blokada also stopped working on my macbook using WireGuard. I suspect its the same problem with the dns service. This is happening since a week or so, no problems before
Please help

1 Like

If you disable Plus on your mobile, and only leave it in Cloud mode, does it work for you then?

(on wifi)

Its not working in cloud mode. Its got nothing to do with plus, VPN.
I cant use the private DNS on wifi

If i set private DNS to and use any wifi, there is no connection anymore and message “Private DNS server can not be accessed”
If I turn off private DNS, internet connection is restored, but obviously no add blocking
This happened with blokada app turned on or off.

Same thing on my MacBook. Profiles don’t filter any ads and when i use VPN with WireGuard all trafic gets blocked , no internet

So, to me it seems something is wrong with the DNS cloud or maybe my account? My plus account is still active and valid for more than 200 days

Just found out its not just Blokada private DNS. I cant connect with any private DNS service on wifi.
I am so lost

Unfortunately it seems like your WiFi is blocking Dns Over TLS. You may try asking your Internet Service Provider about it.

yeah, kinda figured out it had to do with the isp.
Thing is. i’m constantly traveling, every day on a different wifi/isp. it’s only happening recently on almost every wifi i try . Why is that? did something change in internetworld? Or was i just lucky before?
This kinda makes the vpn useless if i cant use it on the road. Am i the only one having trouble with this?

It seems so. What was the thing you had to do with your isp?

I didn’t do anything with the ISP, I cant. because I’m always on hotel/restaurant/public WiFi. That makes this problem so frustrating.

Oh I see. Yeah public WiFis are very restrictive often. They may be blocking DoT protocol. I’d say you may want to switch to Blokada 5, as it’s a different mechanism that may work for you. Otherwise I may offer you a refund (just ping

Thank for the offer, and help.
Still can’t believe I’m the only one having trouble with this. What good is a VPN you can’t always use when using public WiFi

I believe it’s not the VPN, it’s the DoT that is the problem. If you disable your private DNS and let only the VPN run, it should work. You’d need to switch to Blokada 5 from our website though.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.