Blokada blocks every single webpage.. What am I doing wrong?

Hello,
Android 7.1 doogee S50, not rooted.
I had Blokada v4 from Google play, it always blocked everything so i could never use it (unless i was happy not to use the internet, but that defeats the purpose obviously).
I uninstalled and installed v5 from fdroid today, same situation.

I must be an idiot, forgive me but i can’t use it at all, it won’t allow duckduckgo to even search. Not even the help pages from blokada will load. It always says err load page error or something similar.

There was another post about YouTube that seemed to ask this same question, but the developers said they had a glitch they fixed… Well, all i can say is i have had this exact glitch (makes internet absolutely unusable because it blocks every single webpage on whatever browser) for 2 years and 2 versions… The post was closed on Jan4 so i couldn’t reply to it.

Someones please help this clueless fool, many dumb thanks in advance =)

1 Like

Okay, so what block lists have you activated? Also what DNS option have you selected within Blokada?

1 Like

Hello, thanks for answering!
I activated no blocklists. When i turn the blokada on and go to the blocklist aection, it shows 3 options
1.highlights (all left, which i assume is off, i never touched anything),;
2. active, list is totally empty ;&
3. all, which has all toggled left.

Regarding your 2nd question, i selected nothing, it never prompted me to, i don’t know, unfortunately i don’t even see any dns settings section… but i didn’t touch anything. I simply turned it on. Sorry,

Curiously, right now it is on and letting me reload an Amazon page, but i think that happened some year(s) ago too (where it worked once, then later each time i switched it on it prohibited absolutely all online activity, so i just turned it off forever).

I look forward to hearing from you again, ao i can answer follow up queries…

1 Like

Right, this is not a “too many lists on” issue, as you rightly surmised that they are all off.

The DNS option is located in Settings->Encryption & DNS. Unfortunately the f-droid version is a little behind the official version of the app, this might be relevant as there was some trouble with the Blokada dns option (which was default at one point). Anyway if the dns option is (or not) on Blokada dns, please try a different one, see if connectivity comes back.

Hello again,
Without intending to sound contrarian, the dns is NOT in settings. To get to what i would consider settings i select settings - >this device… But it’s not there, either.
Below, i tried to upload the 4 screenshots showing the 2 menu pages, alas this forum meagerly allows only 1

And, to add to the confusion, my v4 was not frim fdroid but from GooglePlay, yet it exhibited very similar behavior …
I await with thanks on advance (you may have to return them later, if need be) and blokada turned off =)

Tap on advanced menu tab then tap on networks:

Now tap on all networks:

Tap on use dns and choose cloudfare.

Thanks, curiously / coincidentally the app requested an update on F-Droid this morning which i immediately obliged… Indeed, I’ve found all you referred to, so I’ll enable and test.
Thanks, fingers crossed!

Sadly, it still doesn’t allow any wifi activity… It does work if i turn off the wifi on the phone… So i have to use my data plan if i want both
1.Blockada on, blocking ads; and
2. i want to work online.
I don’t know, it doesn’t make much sense to me, but then again I’m just an ignoramus…

Oops, sorry about pointing you to the wrong place, I was looking at the iOS version of the app.

Anyway, I’m thinking that something on the WiFi you have is blocking the use of other DNS servers, as the Google v4 app experienced the same problem. It should be possible to switch off the DNS options for your WiFi but sadly I can’t point you in the right direction as I don’t have v5 on my android device, it should be in the advanced networks section at least.

I have actually seen an issue like this when attempting to use Blokada (and another Local VPN block list utility), but only under the following conditions:

  1. Using an Android 7.1 device.

  2. Connected to a WiFi access point which has an unconventional DNS configuration, wherein the router’s DNS resolver for IPv4, differs from the one set for IPv6 (for example, OpenDNS w/IPv4 and Google w/IPv6). Unfortunately, this is a common problem on some devices which are endorsed by Comcast as officially compatible (alternative IPv6 DNS settings are not respected).

When I’d disconnect from such an AP, Blokada would resume functioning as per usual. I wonder if you might be affected by the same problem.

1 Like

Hello Bongochong,
I think that’s probably it. I am only 1 notch above useless, and I know nothing about comcast (not in their monopoly zone) but i do think it’s likely just that. So basically i can’t use blockada at home or on the same carrier’s internet unless i buy a new phone… By the way, i am loathe to do that, because I do love this phone, i have dropped it well over 200 times, bouncing it on granite steps, all kinds of abuse (the camera is sub-par however). Only once did i have to dismantle it and reply the screen into the motherbiard. Bummer. Maybe one day I’ll be able to use blokada.

Since you’re on Comcast, and it sounds like you’re likely using a router/gateway endorsed by them, then it looks like we’ve narrowed it down. I would suggest exploring the DNS settings for your router, and ensuring that the resolvers used under IPv4 and IPv6 are from the same provider, or, if you haven’t made any changes to the router’s configuration, simply doing a factory reset. I encourage you to eventually get a different router though, because they really lock their devices down and limit user choice in pretty serious ways.

Hi,
I am not on Comcast. I’m currently on Orange in Spain. I must have mis-expressed something, though I’m sure Comcast is a horrible company. I guess I should enter the modem here as admin and change things? I don’t know anything (yet) about IPv4/6 but i have done other things from within the router/modem (it’s one device).

Oh, I must have misunderstood. Either way, it’s no guarantee, but it sounds like the issue I experienced myself, and that was only resolved by ensuring the same DNS provider was being used under IPv4 and IPv6 in the problematic router.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.