Blokada 5.9.0 suddenly started blocking almost everything

Hi everyone.
About half an hour ago I was browsing the ebay app on my Android 9 phone when “Bam” I was told there was no internet connection. Checked Amazon and got a similar error. Other apps started throwing up “No Connection” errors too.
Once I turn Blokada off everything is fine.
I have cleared the cache and storage to revert the app back to default settings but when activated it’s still blocking the same apps.
I’ll try uninstalling it and reinstalling to see if that helps but other than that I’ve got no idea why it’s suddenly started blocking everything like this.
If I can’t get it to work I’ll roll back to v4 to see if that works and stay with that until a solution is found.

10 Likes

Change your DNS server it seems blokada dns is having issues

1 Like

Same issued as StickyMick, how can i Change the DNS?

1 Like

OK. Found out how to change it, but it still seems to be blocking everything.
I’ve tried the Blokada DNS, Cloudflare and the Google DNS, but still no joy.

To change the DNS tap the small box like icon at the bottom of the Blokada screen and then tap Networks, then enable “Any mobile network” and “Any WiFi network”. Next tap the “All networks” above. A list of DNS servers will then appear and you can select one from there.

As it still misbehaves after changing the DNS I’m leaving Blokada disabled for now.

3 Likes

Was just about to answer you but you figured it already out by yourself. Not very inituitive BTW.

Had the same problems since updating the app to 5.9.0 and left it disabled for times. I then found out how to change the DNS and switched to Google DNS. Closed the app, restarted it and so on, now it seems to work…

1 Like

Seems to be working again now, using Google DNS.

:EDIT: Damn! No it doesn’t. It keeps coming and going.

Same here. It was working well. Until the update…

2 Likes

Same here in the Netherlands. I had to deactivate Blokada. Still waiting for a fix

1 Like

Same problem. Changing DNS doesn’t help. But found out that my girlfriend still has 5.2 installed, and it works just fine. Tried installing 5.6, it works too.

Thank you so much for the instruction. I’ve overseen the menu above. Now I checking this solution. Also the Blokada downgrade didn’t work for me

Downgrade to 5.8 didn’t work for me either…changing DNS settings didn’t work either… I’ve deactivated Blokada for now

Same problem here in Germany with 5.9.0. The most apps are blocked (some are working). I tap’ed on the small box … then “Apps”, and tap’ed on all the apps, that not shoud be blocked (the apps, that not worked). It’s a bit freeky, but it works. Some apps are at “installed”, other (like facebook) you find under “system”.

2 Likes

this seems to work; set your dns to cloudflare for all networks under advanced:


oh and restart blokada after this :wink:

4 Likes

seems to work, thank you. :slight_smile:

1 Like

Thank you for making this thread - I literally had the same issue and the Cloudflare DNS solved it. I thought it was recent changes I made (changing blocklists, adding an exclusion for the Outlook app) but I’m glad I’m not going crazy/broke something.

1 Like

for me the DNS from Digitale Gesellschaft(Switzerland) is a lot faster than the Cloudflare DNS

StickyMick, did you restart Blokada after changing to Cloudflare?

1 Like

Had the same issue. Changing to cloudflare DNS worked.

1 Like

Yes. I’m not on + so I only have 3 DNS servers available. I had no luck with either of them.

1 Like

Mine even blocks the “Contact us” link in the Blokada help menu.:flushed:

1 Like