Blokada 4.8.5 erratic ad blocking

  1. Where did you download Blokada from?
    Blokada website
  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
    Samsung Galaxy S10e, Android 10 stock
  3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
    Blokada has started to not block ads on an erratic basis.
  4. Since when are you facing this issue?
    A couple weeks?
  5. Did you already try to solve the issue somehow? If so: please state what you did.

Blokada 4.8.5

Blokada has always worked great for me. Lately, for reasons I don’t understand, Blokada has been allowing apps to display ads at times. I have all sleep settings disabled for Blokada on my phone. I have recently set Blokada as an always-on VPN to try to help this issue, if Blokada was being stopped for some reason, but it hasn’t helped. I noticed that occasionally I will get an always-on VPN disconnected message, then Blokada reconnects almost immediately. I do not know why this is happening.

When I get ads in an app, I go into Blokada and check the host log for anything obvious, then clear the host log. I clear the cache for the app that was showing ads, force stop it and restart it to watch the cleared host log for entries, but the app no longer seems to be displaying ads at that point. This is occurring with multiple different apps.

This makes it appear to me that Blokada is ceasing to function even though the always-on VPN shows that it is running. I am mystified by this problem and don’t know how to diagnose it other than by the means I have described. As I say, until recently Bokada worked fine and I can’t think of anything that has changed recently that would have caused this.

Is there any help you can give me on this? I find it extremely frustrating.

(Maybe I should try switching to Bokada 5 since I read that it is now out of beta)

Make sure to disable Private DNS on your phone

A post was split to a new topic: Blokada v5 stops

Thanks for your reply. Private DNS is disabled. This did remind me that I recently set the DNS in Blokada from Default to Cloudflare This should not cause an ad blocking issue, should it?

I tried out Blokada 5, but the apparent inability to whitelist/blacklist specific hosts makes it unusable for me (don’t personally care for what seems to be a dumbed down UI either), so hopefully there is an answer for my Blokada 4 issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hey there:)
Is your issue solved by now?

Thanks for asking! After uninstalling 5 and reinstalling 4, the issue seems to have gone away. I guess the clearing of the data/cache fixed something. Thanks.

1 Like