Android: unable to install update from PlayStore

Hello,

Today in PlayStore an update for Blokada to version 22.4.14 came up. But the update process doesn’t succeed. It always end up like this:

I run Blokada 5 Slim on my OnePlus Nord 2 with Android 12. I use Blokada from the Play Store.

What i can see is, that during update process the local VPN connection is dropped (the Key Symbol from the upper screen disappears). The error message from the screenshot appears directly afterwards.

Greetings

What version are you exactly running while you are trying to update?

Hello Reda, my installed version is 5.21.0.
I wonder why the version string differs that much from the one you just released.

I checked my last posting with update issue and there I had a version missmatch as well:

Did I ran into the Blokada Slim is not the same as Blokada thing?

That’s right Blokada Slim is not the same as Blokada, if you still using Blokada Slim you should uninstall and install Blokada 5 from our website.