Android Blokada 5, VPN Amsterdam yields Swedish Google results

  1. Where did you download Blokada from?

  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
    Android 12 stock, LG Velvet, no root

  3. Please explain the issue as detailed as possible. Also patterns you observed (like ‘it only happens on wifi’). The more information the better.
    Swedish search results in Google on both wifi and mobile networks when using blokada 5 app set to location Amsterdam. Observed getting German search results in Google when location set to Frankfurt. Changing DNS server does not change observed behavior.

  4. Since when are you facing this issue?
    Not too sure but certainly a number of weeks

  5. Did you already try to solve the issue somehow? If so: please state what you did.
    Change DNS server, restart, change location

Ps. Similar situation in this topic: VPN location Amsterdam Netherlands but some sites open in Swedish language - #3 by Mischa

Any ideas as to resolving the issue? Many thanks!

Hello, please refer to

The location databases aren’t always correct, Google probably sees that the ISP behind Amsterdam is indeed Swedish and falsely assumes also the network is in Sweden


Thanks for your reply. Other than setting Google search region to NL do you know of a workaround?



Unfortunately Google seem very persistent about it.
The only workaround I can think about is to login with your Google account or try a different search engine. Also of course there’s the opportunity to learn Swedish, I think it’s a great language :wink:

The IP registration clearly says which country its registered in:

inetnum: -
country:        NL

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.