Android 12, Beta 4 - Blokada no longer works

Greetings. Pixel 3xl and just installed Android 12 Beta 4 today (came out today, 8/11/2021). Using Blokada 4.15.

App runs, but not traffic passing through it; nothing is blocked. All ads are back. Uninstalled, removed VPN connection, reinstalled, deleted cache and data, put vpn connection back, tried “always on” VPN, etc., etc.

Hopefully an update will be forthcoming to support Android 12 Beta 4? FYI: Betas 1-3 worked fine.

Thank you. Long-time user and donator.


I’m having the same as I problem I even had to go in and turn back off private DNS but still no luck

Same here. It stopped working after update to android 12 beta4

On Pixel 5 Beta 4 same issue. Ads everywhere

by the way; thank you @devs for blocking this mess up to Android 12 Beta 3. Android is not usable without Blokada

Guys, please share your logs to, mention the android12 issue. Maybe I can find something.

Log is on the way

Same here. Android 12 beta 4. Pixel 5. Will share logs.

I was curious so I tried another DNS based ad blocker. And it also is failing to work. Dns66 by the way.

Seems to be a VPN bug in android.

1 Like

Sent my logs.

1 Like

How is this issue resolved? What is the resolution? It’s still not working for me.

No rez yet. Another user graciously provided devs his log files. Will likely take time. Fingers crossed.

Just sent my log file too. Thank you

It appears that Google might have done an oopsie:

In other words:
We can’t do anything. Google has to address this
Maybe the new Blokada beta might address this


Well, darn

So, with other words, we have to wait for Beta 5?
My Pixel 5 get empty sucked by Ads. There are so many of them, everywhere :sweat_drops:

Or go back to another version of Android that doesn’t have the bug.

Looks like the only vpn working after reading the article is google’s one, think that says it all. Will wait and see!!!..

1 Like

The Blokada 5.16 beta seems to be working!

1 Like

This would be a surprise since I did not change anything that could affect the problem, in that update. Nevertheless good to hear!

unfortunately the problem is still there :cry: