"Blokada DNS" stops the internet

Long time Blokada 4 (B4) user. I know its no longer supported.
Issue is specifically about Blokada DNS, which stops the internet the moment I switch B4 ON!

I did download B5! Internet does work with B5 (default network settings) but DNS in B5 doesn’t block ads, at all. Its like VPN isn’t filtering the tunnel. For instance: Chrome browser has no effect of VPN filtering with B5. Ads continue to appear.
So, the only difference between B5 and B4 is that I can use internet but still the core function of adblocking isn’t happening due to Blokada DNS not working as it should.

Has Blokada DNS stopped by developers after switching to Blokada 6 cloud support? What should I do now? Because Blokada 4 is flawlessly working. Only issue is Blokada DNS has stopped responding and even blocks internet usage completely

  1. Platform: Android 9
  2. Device: Xiaomi Mi A1
  3. Since when are you facing this issue? - Past 1 month.


Thanks for breaking down the situation.

Were you able to run the adblocking test to compare Blokada 5 and 4?

Thanks for the response

I took the test with B5 (default network with DNS settings- clouflare: malware+adult blocking)
Screenshot attached of the results

Blokada 5 Json file

I couldn’t take B4 test because the app simply blocks the internet when switched ON with any DNS selected.


Can you double-check in your DNS settings if you have Custom DNS set as “Off”?

It’s off. I have gone through all the steps listed by another thread on troubleshooting. I even discussed with my service provider (JIO net) and they are not able to answer either. Its fine at their end.

Blokada 4 has clearly a Blokada DNS problem, which stops the internet.

Blokada 5 while internet functions has a different problem- adblocking isn’t working! No matter which DNS settings I pick (incl private network settings)

Let me also share another interesting thing with B5

When I browse in chrome, adblocking filtering isn’t working but when I browse in Firefox browser the DNS seems to be filtering the internet at server end. Certain sites simply don’t open which I can browse in Chrome. While adblocking is still not working in Firefox

I’m not entirely sure what’s causing this inside Blokada 5.

If you have followed the setup correctly your score should be at least 70%.

I’m curious, does this happen on Wi-Fi or Mobile Data?

I’d recommend you try using the Network Feature by going to Advanced Tab → Networks → Select your Network → Click on Prefer Network DNS

Please make sure that all the right permissions are given to Blokada.

I don’t use WiFi. Only Mobile network. I tried Network DNS. Doesn’t help either.

Here’s an example with Firefox Browser to make it easy to understand. Blokada 5 is ON.

Now when I launch pastedownload.com site you will notice a message on the site asking to turn off adblocker. This indicates default cloudflare DNS is working! If I open the site in Chrome the adblocking doesn’t work be it server end or app

BUT when I check the log of Blokada 5 apart from site being allowed there’s no information on which host was being blocked. This means app is not blocking the ad. Its happening ONLY at the server end.

Adblocker is default OISD

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.