Wiregaurd on windows 11 pro

I have been using wiregaurd on windows for a few month now, everything worked seamlessly until yesterday. now when i activate, wireguard blocks my internet access. Deactivate, internet fine. I’ve uninstalled and reinstalled, deleted profile and reconfigured but still blocks internet. not sure what i should do next.

I have checked logs and i am continually getting :
2023-08-04 21:08:31.577: [TUN] [blokada-2308] Sending handshake initiation to peer 1 (

2023-08-04 21:08:36.725: [TUN] [blokada-2308] Handshake for peer 1 ( did not complete after 5 seconds, retrying (try 2)

over and over, anybody run into this?


Your issue might indicate that the VPN connection is being blocked in your network or possibly an outdated configuration. Here’s what I would try:

  1. Download the configuration again to ensure it’s up to date.
  2. If you have the ability, try connecting to a different WiFi network or consider using your mobile data to check if there’s any improvement. This will help determine if the issue is specific to one of your networks.

Give these steps a try and let me know how it goes.

yeah, you are correct. I was trying to delete and configure the same location profile. After i tried a new location it began to work again. somehow the blokada dns server is blocked now with the previous location profile no matter how many times i delete reconfigure and upload, but seems to work on new location config. what would cause this? anyhow thanks for your help.

also, while i did not have access to the vpn i tried to manually configure the dns. I changed the ip4 dns address and hostname and it saved as the new configuration (see attach) but my computer still uses the defaut isp dns. I used an online dns info page to test. any ideas why?


I’m glad to hear that trying a new location resolved the issue! The problem with the old configuration could stem from a few reasons:

  1. Accidental deletion of the “device” profile, either manually or automatically when generating a new one on the web app.
  2. It’s possible that the specific location, like Denver or London, underwent some maintenance, which might necessitate a new configuration.

If the problem reoccurs without any apparent changes on your end, please reach out so we can delve deeper into the situation.

Thank you for supporting Blokada by using Blokada Plus!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.