MacOS Blokada VPN IP check shows actual instead of virtual location

I have installed the profile for London VPN . It shows it is running under Network in MacOC System Preferences > Network. When I run a Whatismyip check the result shows my actual location and not the VPN set location. What is wrong?


Please distinguish between the Blokada Cloud and Blokada Plus functionality.
Installing the cloud profile alone doesn’t provide any VPN features as described here:

Did you successfully connect to the Blokada Plus location with the WireGuard app?

Hi, I have now installed the Wiregaurd App, generated tow LONDON config files; one with Cloudflare and one with Blokada DNS in Blokada VPN, imported and activated it in Wiregaurd. However, when activating either, neither allow a connection to the internet even though they both say connected (see pictures). Once I deactivate the config I can again connect to the internet on my default DNS servers.

I am sure I am doing something wrong. Any ideas!?

Screenshot 2022-07-04 at 15.45.41

Screenshot 2022-07-04 at 15.41.47

Hi, it appears the problem IS with the London VPN as I can connect to the internet without a problem when I create a New York VPN.

Thanks. When I create a config with a New York VPN I can connect to the internet but when config for London VPN.

Are you able to confirm the service for London VPN is down now?

Not with Blokada Cloud directly, maybe it’s different with Wireguard. I’ll investigate and get back to you about this.

London works with Wireguard


Are you still experiencing issues?
If so, could you:

  • Remove the existing London config in VPN devices menu on
  • Delete other configs in your WireGuard app
  • Create a new config in VPN devices menu (not Blokada Cloud menu) on, leave default DNS setting as is
  • Import this one config file in WireGuard
  • Activate
  • Navigate to as well as to see if any or both works

Sorry for the trouble

Yes this is working now. Thank you for your help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.