VS CODE - Github Copilot does not work with WireGuard VPN activated on Windows 10 PRO

I recently downloaded WireGuard for Windows 10 since I’m a Blokada Plus member and although everything is working fine on Windows 10, I noticed one issue within VS Code on the Github Copilot extension. For some reason the copilot extension can’t connect to the github server. The only way it works is if I deactivate the VPN on WireGuard.

Have any of you experienced this? Any input would be appreciated.

Please try to check your Logs in our web panel. There should be some blocked items that you may need to unblock.

When you say logs, are you referring to ‘log’ tab on the WireGuard app or there’s like an actual website for that? If so, I tried looking and I don’t see any new incoming requests (on WireGuard) whenever I try to start VS Code. I’m very new to the VPN world and it’s my first time using so more probably might have to do a little more research.

I did notice all the logs are from [TUN][Blokada] and most of the logs I see are 'sending keepalive packet to peer 1 (xx.xxx.xxx.xxxx:xxxx) or keypair xx created for peer 1. As far as disabling or enabling anything there I don’t believe that’s option.

Any further guidance/input would be appreciated.

I am referring to the Activity tab in https://app.blokada.org where I assume you took your Wireguard profile from.

Thanks, I was able to find the activity feature now. However, I forgot to further add I’m using WSL Linux on Windows so it just seems like I’m not able to resolve any HTTP/S hosts. If I want to clone a repo or even sudo apt update Ubuntu through WSL, I get a can’t resolve error: Could not resolve host: github.com. Not just github, but basically any online connectivity seems to be ‘off’ unless I disable the VPN :sweat:

I was able to fix the issue and just wanted to update here just in case anyone has the same issue down the road. If you’re using WSL through windows, the VPN (Blokada wireguard) usually blocks the network connection when you’re trying to download or update your Linux environment.

What worked for me was making sure I added WireGuard’s DNS server IP address on the resolve.config file as well another nameserver ip address of either or (up to your discretion) and I also created a wsl.conf file and added other options within the ‘etc/’ folder of Linux. I’m not sure if I’m supposed to copy/paste external links here but by at least knowing this, there is fix to this issue should anyone else go through the same.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.