FYI: date and time can affect wireguard/blokada from working on Windows 10

Hi all,

This is just an announcement after my troubleshooting. I’ve been running blokada “pro” or whatever it’s called via the oficial wireguard application on windows 10 totally fine for weeks/months.
Today I booted the same computer onto an arch linux live USB to do some stuff, and also went into the bios to access the boot menu.
Anyay when I came back to Windows i had no network connectivity.
Wireguard was connected but had no throughput. I troubleshooted this for over an hour, seeing as I had no clues. I disabled it and the net worked fine but obviosuly wanted to fix.
Ironically, it was trying to get to this forum that solved it for me. In Firefox Developer Edition, i searched in DDG for blokada and hit the forum link. I got certificate errors that i could not bypass, and after reading it carefully it said that if my computer’s date an time are correct then the website is misconfigured. I almost didn’t even bother looking at the computer time, but then i glanced at it and it was in UTC time. I just happen to know the difference with UTC time. I manually changed it to the correct time and connected to wireguard and voila, it worked immediately, as did this site.

So, hopefully this can help someone else one day.

The log was full of messageslike this:

2022-04-14 05:56:48.739183: [TUN] [blokada-5555] Sending handshake initiation to peer 1 (
2022-04-14 05:56:53.874709: [TUN] [blokada-5555] Handshake for peer 1 ( did not complete after 5 seconds, retrying (try 2)

Welcome to the amazing world of certificates and windows.
It’s weird.
But it somehow works.

1 Like