Test site providing inconsistent results on Chrome with v5

I do believe that you may have misunderstood the OP. As example, i just went to the test site, and received a 98% blocked. Checking the listing, it says that Blokada failed to block a Sentry error tracking site (shown as red on tge d3ward test). Okay, so check the Activity tab in Blokada (Libre), it is entirely red, not one site allowed, not even the test site itself. So how can one block a site that the test says was “not blocked” (red on the d3ward test site), when it shows as neither red (blocked) or green (allowed) on the Activity tab?

To further confuse the issue, the above was on my tablet. So… go to the my phone immediately after, and tge d3ward test site says 100% blocked, including thos Sentry error trackers. This is using the identical Blokada set up on both phone and tablet, from the Blocklists, to the Exceptions. And here we go again… do the test yet again on my tablet, and d3ward says 46% blocked, but the Activity tab in Blokada is nothing but red (blocked sites), not a single site shown as green (allowed).

So which is right… the d3ward test, or the Blokada Activity tab? And if the d3ward site is correct, how can we create an Exception for the sites it says are allowed, if the Blokada Activity tab doesn’t list the supposedly allowed site?

You must have only blocked entries selected, you have the possibility to select which entries you want to see on the top right next to the search button, by clicking on it can either show “blocked entries”, “allowed entries” or “all entries”.

I ran some tests myself to answer your question correctly, I ran the test on d3ward and got 90% with a few domains not blocked (shown in red in d3ward), the example we are going to go with here is the link from Amazon “https://analyticsengine.s3.amazonaws.com”, so I went to app.blokada.org and searched on the activity tab (don’t forget to delete “https://” if you want to run the same test) by pasting the domain from amazon. Now in Blokada it is shown as allowed ( in green) which is normal, so I had to add it to blocked entries, and I did that to all the domains shown in Red on d3ward.

Now to test if that made a difference, I closed the browser and opened it again (to get accurate test results) and my score was 99%, and all the entries were shown in green in d3ward.

I hope this answers your questions and let me know if you have any other questions,

First, to be clear, my Activity list is set for all, as it has always been. I have been beta testing for a long time now, and would never make such a change from default without a legitimite testing reason, and would change it back immediately after any such test. FYI, duplicating your test was not possible, since the entry i used for testing (ads.google.com) showed as allowed in d3ward, but not in Blokada, and a search for it showed nothing, although, in a later test it showed as blocked in both.

My testing methodology… to start, using Syste…Apps…Storage, i cleard tge cache for both Blokada and Chrome, and tgen cleared the Activity tab in Blokada. Then i ran 5 “tests” using the identical procedures… run the ad blocker test, note how many, if any, items were allowed, closed Chrome and checked the Blokada Activity tab for allowed entries, then cleared it and started over immediately, doing nothing else in between. There were no changes to Blocklist, Exceptions or any other settin in either Chrome or Blokada. The results of the 5 tests…

  1. ad blocker test, 100%. Blokada showed 3 allowed entries, which were legitimate (background checks for updates in other beta tests i am in).
  2. ad blocker test, 67%, with 16 allowed categories. Blokada showed 2 allowed sites
  3. ad blocker test, 67%, with 16 allowed categories. Blokada showed 1 allowed sites.
  4. ad blocker test, 67%, with 16 allowed categories. Blokada showed 2 allowed sites.
  5. ad blocker test, 71%, still with 16 allowed categories. Blokada showed 3 allowed sites.

In no case above did Blokada show as green (allowed) anything except my anticipated and allowed sites (weather.gc.ca, apps, kustom.rocks)…

That’s odd. You shouldn’t be able to reach the site if that’s red. Are you using Google chrome and blokada cloud?
If you’re using chrome:
Ditch it. Right now. Go for brave or bromite instead.
It does not seem possible to deactivate asynchronous DNS in chrome these days which is what normally leads to inconsistent results.
That might change if you specifically set chrome to use Blokada cloud.

Have you tried to look for entries using the search button?

Reach the site? Reach which site? In my testing, at no point didi try to reach any site allowed ineither d3ward or Blokada. All i attempted to do is match sites not blocked on d3ward to sites allowed in the Activity tab of Blokada.

Yes, i am using Chrome and have been for some while. I tried Edge (even beta test on it, since resigned) and Brave, and neither one suited me or my style of working, and lasi i checked, neither allowed the setting of flaga to customize the browser. Chrome and Android 9.0 allow the use of a Private DNS (in my case, set to automatic in order for DNS Test to show my DNS as Blokada. Additionally, Chrome can be set to only use DoH (https alone and Blokada DNS. The same applies using Loudflare as DNS.

And no… i have not searched for any entries at app.blokada.org. as i stated previouly, this is Blokada Libre, not Plus or Cloud my only location to search is the Activity tab on Blokada Libre for android. I have earched there for some entries allowed by d3ward, but as i stated previouly, d3ward often lists 16 to 20 tests as being allowed in part or all, which could mean looking for 16 to maybe 30 or more web addresses. Generally, after 5 or 10 searches of the Activity tab with negative results, i tended to not waste any more time

And i can not specifically use Blokada cloud… this requires paying for Plus, and as a senior citizen on a very limited income, and tight budget which does not allow for a monthly subscrition of 5 or 10 Euros. As a result, i use Blokada Libre.

I think there’s a miscommunication, you made it sound like the test site linked in the “What is Blokada Cloud” post was blocked. I’m guessing that’s not what you meant?

Don’t do any of that on Libre. Make sure to turn all these chrome settings off - not automatic but off.
If you’re unable to find any blocked or allowed content in your hostlog made shown chrome at all chrome is rerouting the data effectively bypassing blokada.
Blokada dns is not supposed to block any content at all.
It’s important that your android blokada app isn’t bypassed by Google chrome. That’s what they do with “asynchronous dns” or “async dns” or “data saver” and similar features all of which have been discussed here already:

I’d ask you to look through your chrome flags and settings for these features and turn them all off if you want to continue to use chrome. If that’s done and your browser cache is cleared we’ll have a look again.

My apologies, but all of those settings have been properly set since they first appeared here as recommended… and to be sure, i just double checked. Also, checked all of my Chrome flags (nothing for DNS or HTTPS… basically only flags having to do with password display in settings and dark mode for all sites). I then ran the test again at d3ward, and yet again had a result of 47%. The first ‘not blocked’ entry was ads.google.com. A search of the Activity tab showed nithing, neither blocked or allowed. IOW, no change. To be sure, i also cleared the cache in both Blokada and Chrome and got a similar result (except even worse… 32% blocked on d3ward test)

  1. Once again… i am not using Blokada Cloud, but Blokada 5 on Android. Thus, any inconsistencies occuring in the Cloud have nothing to do with my problems.
  2. my Blocklists on both the phone and tablet are : DuckDuckGo Tracker Radar, Developer Dan’s Hosts, Combined Privacy Block Lists and 1Hosts.

The method you use in the video is only workable if the site that should be blocked is shown in the Activity list as being allowed. Since, on my setup, a search for that site results in an empty screen (and a visual search of the list’s green (allowed) entries likewise does not show the sites not blocked in the d3ward test) i cannot mark them manually as blocked since i can’t enter a site manually by typing it in.

Try again with a browser other than chrome

My alternative browser is Edge, which behaves the same way, with inconsistent results, and not showing the entries as not blocked in d3ward, in Blokada Activity tab, not listed at all, either blocked or allowed.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.