Private dns server cannot be accessed


Platform - Android 12
OneUI version 4.1
Phone - Samsung sm-g975f
Blokada cloud downloaded from Google play store - last updated 23/06/22

Was working well from install but today stopped working with message -
Private dns server cannot be accessed.

Have tried restarting Blokada and have also restarted phone with no success.

Any ideas?

Regards, Rob.

Is the issue still persisting? :slight_smile:

Yes the problem is still continuing, both on Wi-Fi and mobile network.
I have also tried uninstall and reinstalling with no success.

That’s… Weird. Can you DM me your log or send it to while referring back to this post?
Edit: Log received. We’ll be with you as soon as we’re through the suffering of reading it :slight_smile:

I have been having this issue as well since yesterday

Hard to say what it is. We can see your DNS profile config being reported as correct and incorrect back and forth. Either you’re changing it (the paste string that has to be pasted) or there’s some kind of device issue.
So recommended steps:

  1. turn off plus vpn (no location selected)
  2. clear the private dns configuration in the settings
  3. enter Blokada and follow the setup guide again (paste the config)


Yes, I have already tried doing that,. After that failed I tried completely uninstalling and reinstalling Blokada also without any success.
Sorry if I did not mention trying this.


I have just;
1- deleted Blokada, data and cache,
2-cleared private dns configuration in settings
3-rebooted phone
4-reinstalled Blokada
5-restarted Blokada (no vpn selected)
6-followed setup guide again (pasted config)

This did not work, (private dns could not be accessed)

I then went through steps 2 - 6 again after making sure no vpn plus was selected in Blokada.

After this also did not work I generated a new logfile, in case this would be shorter and easier to read and maybe clearer what was happening.

Regards, Rob.

Please do not share logs publicly in the forum. They contain sensitive data

Sorry . Thank you for editing it.

The logs seem to be showing unsolvable somewhat erratic system settings changes. The app itself is not involved in this. It seems like android is acting up.
Unluckily - given these circumstances - the only thing we can offer you is a refund and no fix. :confused:
Contact for more

This does look like an app issue, I’m able to copy an alternate private dns and it connects without issue

You’re a different user with a different device and possibly different log activity.
To dig into this please create your own post and share a log with us.

I reinstalled app as per OP steps last night created a log and have emailed it through as part of the refund process above.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.