Unable to connect to Private DNS after software update

Hi,

I’m on a Samsung S23 Ultra, Blokada 6 with cloud subscription. All was working fine until today I had a software patch update pushed down from Samsung. After that, Blokada stopped working, giving me a notification that the Private DNS cannot be accessed and there was no network connection.

Went into the phone settings and switched Private DNS to off, which results in recovering the network connection. However, going back in to Blokada app, it states that the Active DNS had to be configured. So I copied the DNS address provided by the app, went back into the phone DNS settings, switched to Private DNS, pasted the DNS address and hit Save. Same error was given, Private DNS cannot be accessed.

I had to switch it back off to use the default network DNS else I will not have any network connection. Please advise what to do next.

Edit: I’m not on a custom ROM so there is no way for me to roll back the update.

Hey @Poppienutshell ,

Thanks for posting this, we’ll need the log to be able to take a closer look.

Can you please share your log with us via hello@blokada.org and refer to this thread?

Same issue for me on Samsung S24 Ultra unlocked version. Happens twice to three x’s a day. Annoying. No idea why but thinking about stopping Blokada 6 and going back to Blokada 5.

1 Like

Hello,

Thanks for confirming this also happens for you.
We’re still trying to figure out what might be the reason.

The suspicion is that the built in firewall feature might be causing issues.
Could you try configuring the Knox firewall to specifically allow the private dns service? It should be something like these steps, but I’m not 100% sure as I don’t have the same device to try with.

  1. Open the Knox Manage app on your device.
  2. Go to Settings or Configuration > Security or Network Management > Firewall or Firewall Rules.
  3. Select Add Rule or Create Rule.
  4. Configure the rule:
    • Set Rule Type to Allow.
    • Set Protocol to TCP.
    • Set Port Number to 853.
  5. Save or Apply the changes.
1 Like

We are working on the problem. I would appreciate if someone experiencing this problem with Samsung S24/S23 Ultra (or other one too), would paste us what version of the system updates are you on.

Go to Settings → software update → download and install

It should show you “Update information” if you are on the newest. Please take a screenshot and send to me privately on PM. Thank you!

I do not have this Knox Manage app installed on my phone. Do I actually need it?

No if you don’t have it, you don’t need it. Are you by any chance using any kind of work profile, configured by your employer or such?

So guys to sum up, my questions are:

  1. Are you using samsung knox manage, or are using a work profile, anything work related? This could cause network issues.
  2. Are you experiencing the connectivity problem both on your mobile network, and on wifi network? Please try to switch around and let me know.
  3. If you haven’t yet, please send the software update info to me on PM.

I hope to figure out the issue asap. I got access to S24 to help you with this problem. Thank you!

There is no firewall in settings for me to try and adjust

How do I PM you my update info

No not on a work profile, this is my personal phone. The problem occured regardless on mobile data or wifi.

Not using knox, this is not for with or any other profile. Mobile issue only .

Sorry, mobile and wifi, doesn’t matter which

Now this shows up when using Google search.
Research is showing VPN causes this on Google search.

this network is blocked due to unaddressed abuse complaints about malicious behavior. this page checks to see if it’s really a human sending the requests and not a robot coming from this network.

I see, could you try to deactivate the VPN (so in Blokada, turn off the Switch so it gets from Orange mode to Blue mode. Let me know if then it started working or not.

I’d like to add one question as well:

Does other dns providers work for you without issues?
Try configuring for example dns.google or 1dot1dot1dot1.cloudflare-dns.com for a while in your private dns settings.