I have no connectivity on Chromebook with Blokada on

You just have to turn off Secure DNS (also known as Private DNS).

How to turn off Secure DNS in a Chromebook:

  1. In the chrome BROWSER hit settings (3 dots upper right). Do NOT go into Chrome OS settings.

  2. Click PRIVACY AND SECURITY (left column)

  3. Click SECURITY

  4. Scroll down and uncheck USE SECURE DNS

Now your connectivity should work just fine.

1 Like