Gboard's Voice typing doesn't work if blokada is enabled and no network


I’m using Blokada 4 (downloaded from F-Droid)
Device: Xiaomi Redmi Note 9S with official EEA ROM on android 10.

Voice typing is enabled on my device with offline packages installed.
However, voice typing doesn’t open/initialise when blokada is running AND not connected to the internet (wether Wifi or cellular network)

To sum up:

  • Connection to the internet ON + Blokada ON: -> voice typing OK
  • Connection to the internet OFF + Blokada ON: -> voice typing KO
  • Connection to the internet ON + Blokada OFF: -> voice typing OK
  • Connection to the internet OFF + Blokada OFF: -> voice typing OK

To start voice typing, use the gboard keyboard and touch the “microphone” icon.

  • Voice Typing OK means it invites the user to speak, records and transcripts what I said.
  • Voice Typing KO means it show very fast “intialising” and then it seems to abort and there is no possibility to record anything.
  • Connection to the internet means: either by WIFI or by Cellular network

I also tried to allow all applications and all system applications to bypass blokada, this didn’t fix the issue.

Anyone else experiences this ? Do you have any workaround or shall I file a bug report ?


1 Like

Hey there and welcome to the community:)
Wow, thank you for this detailed report! You did a lot of steps to troubleshoot already!
Did you reboot your device after bypassing the app(s)? If not, please try this and check whether it changes something?

Thank you for your reply.

Did you reboot your device after bypassing the app(s)? If not, please try this and check whether it changes something?

I didn’t do that, but after trying it, the result is still the same: voice typing aborts.

BTW to be more precise than my first post: the problematic observed behaviour when clicking the microphone is:

  1. it invites one to speek
  2. I say a few words, but nothing from what I say is transcripted and voice tying aborts (while normally it does transcript and stays on for more recording)
  3. when I click again the microphone it immediately aborts without inviting to speek (“initializing” wording appears quickly and aborts)

(It is the same behaviour whether all apps are bypassing blokada or not)

Some more information:

  • Blokada ON + Connection to the internet OFF + Flight mode ON => Voice typing works

But it is not useful to enable flight mode to voice type SMS… So this can’t be a workaround for me.

I also noticed this (when blokada is OFF):

  • If voice typing has a network connection (mobile or wifi), display is as follow (this suggests it will transcript by calling google’s servers ?)

  • If voice typing doesn’t have a network connection (mobile OFF & wifi OFF or flight mode), display is different as follow (which suggests it uses the transcription of the phone ?)

So, voice typing seems to behave as if it considered “VPN in use” equals “network available” (even if I have neither cellular data, nor Wifi)

These are hypothesis. Not sure if what I say makes sense.

Any ideas ?

Yes, it seems like the VPN connection gets detected. This is not really some behavior that Blokada can influence.
Three ideas for a solution:

  • You can try to use Tasker or a similar app on v4 to automatically disable Blokada when you disable Wifi/cellular data (but as I don’t use tasker, I don’t konw how or whether it works at all. But here is a little guide: Automating Blokada's behaviour with Tasker)
  • In v5 there will be (it’s not yet implemented) the option to pause Blokada for a specific time frame, so it re-enables itself afterwards again.
  • Use the QS Tile or a Widget to toggle Blokada on / off

Are these ideas that might help you?

1 Like

Thank you.

In my opinion, this should be automatic and transparent to the user so the only workaround that is acceptable is the 1st one. Toggling manually would be too long or complex.

What is “QS Tile” ? (I’m new to Android)

These Tasker apps are awesome ! I used an alternative : “Automate” After a long time trying different ways to achieve it with Automate I managed to make it work. It was not that easy since it seams the automatic VPN activation/deactivation (triggered by Blokada) might be detected as network On/Off and disturbing the way the rules/flow work.

I wanted to attach the “flow” I created for Automate in case someone is interested, but it seems I’m not allowed.

1 Like

Sure, you are very welcome:)!

What should be transparent to the user?

The QuickSettings Tile = In the pull-down status menu (where you can enable / disable GPS / WiFi / flight mode) you can enable a little Tile for Blokada as well. It looks something like this:

Awesome, yes, please attach that “flow”, that would be great!
What exactly is the error you are getting/ the file you want to upload? If it’s basically code, you can post that in a message maybe?

What should be transparent to the user?

I mean the user shouldn’t have to worry whether network is reachable or not and do some additional action depending on that.

Ok, thanks for the BS Tile.

The file is binary. I trired to attach it by inserting a picture, but it says format is not allowed : “Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, heic, heif).

May I post the “base64” encoded version of the file? It’s 7 lines long.

1 Like

Okay, well if the app doesn’t actually check the network status but the activity of the VPN this is not a behavior Blokada can influence. You could ask Google support for a reason why they implemented it that way maybe?


Yeah, upload the file, that should be no problem:)
It seems the picture you wanted to upload is not a jpg, jepg or png - I had the same problem once and using .png did not bring any problem for me so far:)

Filename : Blokada auto turn off.flo
Base64 encoded file (since the file cannot be attached directly here):


You have to base64 decode this to a binary file so that Automate can open it.

1 Like

Posting it as plain text was a very good solution! Thank you very much for sharing it with us:)!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.