Cannot get functions of Blokada+ 5.18 to work?

Android- stock Samsung
Note-10 (Android 12)
Version- Blokada 5.18.0
dwnl. location-
(I believe)
Sub- Yes since 1-27-2022
(noob here lol)

Hello, I have had Blokada for a few days now and haven’t purchased until last night, I have scrolled these topics/ Freq. ?'s, support, Android, VPN, DNS, connection issues, support, etc. everything was smooth at first app showed orange ring, but no VPN in app, still showing libre in app, settings in app are- Blokada cloud/Y, start on boot/Y, keep alive/Y, ping network/Y, I have visited and have set up all the same necessary controls as in app, It may have disconnected while inputting another device while in the online dashboard, that’s when I first noticed it. I am also using both wireless and mobile network, when I fill in necessary info to get the Blokada cloud click to copy and go to settings to private DNS to paste and start I get connections failed, never have been able to access after getting several times, restarted several times in the config client on dashboard, I also haven’t deleted app and started over, afraid I’d lose the unique ID. HELP! :laughing:
(Any and all advice is greatly appreciated! :slightly_smiling_face:)


Please be aware that Blokada v5 and Blokada Cloud cannot work together at the same time.
You need to choose one of the solutions.

If you configure Blokada Cloud via the private dns setting, you should delete the Blokada app.
If you chose to use the Blokada app, turn private dns off.

We will improve this interoperability in a future Blokada v6 for Android.


Hey thanks for the input friend, so how do I continue to use the VPN?, Does it work through Blokada Cloud automatically?. What’s the preferred method for the most secure and anonymous setup?. Thanks in advance :grin:

If you chose to use Blokada Cloud and uninstall the Blokada v5 app, you can still use the VPN by installing the official WireGuard app.
The WireGuard configuration file can be downloaded on

You can read about the benefits of Blokada Cloud here:

Both solutions are fine, the choice of which to use is up to your preferences. Just don’t try to use both at the same time :slight_smile:


Ok thanks alot! info greatly appreciated, I’ll get right on it. One more thing and I promise I’m leave you be lol. Any advice on a good blocker list combo?

The default list is OISD, it works great in most cases.
You can experiment with additional lists when you experience that something is missing or if you know in advance you want to block something extra :slight_smile:

Blokada Cloud also allows you to add entries to your own list just as with the app, but through the web dashboard.

Ok thanks again! Your awesome brother :wink:

1 Like

**EDIT I have completed the above advice to the T and to no avail… I’ve deleted the app, generated new I.D. and posted it to my DNS, at first it worked… Few minutes later I get a notification showing I haven’t got a connection. VPN is instant lnstalled and working, but can’t find DNS.


Oh no! You are using WireGuard and private dns at the same time. Just switch off private dns and everything will go through the vpn connection.

As balboah said:

Hi RPMozley thanks for the response, I actually can’t get it to work, don’t know what I’m going wrong but I do have DNS off, I copied and pasted the Blokada VPN in the setup manager, applied it to Wireguard app, deleted the Blokada app, and am trying to go through the cloud. But when I activate the VPN I can’t get any connections?

Ok, let’s start with your Blokada account first.

1, Is Blokada plus subscription active?
2, Cloud subscription also?

For wireguard you said you copied and pasted the connection settings, I thought you get a configuration file for that. I don’t have b+ vpn so I only know what has been said about it.

Anyway, it seems like the wireguard setup isn’t quite right. If you have B-cloud set in the private DNS ok, it’s probably best to only have that on for the moment and keep wireguard off (until you can get it working correctly).

1 Like

Yes I have Blokada+,
Yes cloud is up and running, and yes you are correct, I downloaded the config. File and uploaded on the Wireguard app. Thanks by the way for the help. BTW I thought you can use Bcloud and VPN together? That was my understanding from all the documentation and help sections?.

Yes you can. If you’ve set the blokada cloud dns to be used in the wireguard config file you just created.

1 Like


So to summarize:

  • private dns off, wireguard uninstalled, blokada uninstalled = has internet
  • private dns off, wireguard uninstalled, blokada app active = no internet
  • private dns off, wireguard on, blokada app uninstalled = no internet
  • private dns on, wireguard uninstalled, blokada app uninstalled = no internet

Is this correct?
And does it stay the same while on WiFi as well as while on mobile data?

*private dns off, wireguard uninstalled, blokada uninstalled = has internet
*private dns off, wireguard uninstalled, blokada app active = no internet
*private dns off, wireguard on, blokada app uninstalled = no internet
*private dns on, wireguard uninstalled, blokada app uninstalled = no internet

Sorry for the delay very busy at work currently.:confounded:
Regardless of I am using WiFi or data cannot get service through the VPN?.
Thanks for the help.

Ok thanks I thought I understood it correctly, otherwise it would have made this useless to me :laughing:

How do you know your helpless?..
When support quits supporting to you! :rofl:

1 Like

I’m very confused by this discussion and what the current situation is :slight_smile:

As I understand it you currently don’t have the Blokada v5 app installed, you’re trying to get Blokada Plus (VPN) working with WireGuard. While WireGuard is deactivated, Blokada Cloud is working fine with the private dns setting.

Also you already tried connecting both on mobile and on WiFi.

Is this the current state?

Hi Balboah, ok sorry about that… I’ve answered your questions above, all of your questions are typed out than answered by me in BOLD.

I didn’t undersand the whole picture from the previous answers, that’s why I’m asking if the current state is as I described or not :slight_smile: