Blokada isn't blocking Google ads

Mine says 72%, and it says that are red, which probably means they’re not being blocked.

Why ever not?! This only changed after I upgraded yesterday. Surely this is the MAIN source of adverts, and should be blocked by default?!

So how do I add it to a blacklist? I read this:

But it doesn’t help. i.e.

" Step 3: Adding it in Blokada

One possibility is to store this file on your phone in Download/Blokada/filters. Then tap in Blokada Ad blocking / Host lists on add new Host list."

Where is this? There is no such option on the UI. Any clues? Has the UI changed recently?

Thanks for your help!

1 Like

Custom block/host list is only available for version 4 of Blokada. Version 5 does not have this option ((currently)).
Visit the test site again and switch to Blokada’s activity tab and look for the domains not blocked. Manual tagging is the only way to add domains.

1 Like

Thanks for your reply. So why did it remove such a useful feature?

And how do you tag manually? I googled for info but found nothing.

Thanks again.

1 Like

In the activity tab, tap the allowed domain and you’ll get the option to block manually.

I can’t really comment on why the feature was removed because I don’t know the exact reasons.

Thanks, that helps, but it seems android apps are bypassing blokada.

e.g. I open an app, see adverts, check blokada running log, and NOTHING shows up :frowning:

I guess I’ll try reinstalling from scratch.

No change. How come suddenly blokada stops working? I don’t get it.

I’ve not upgraded my phone. It makes no sense.

e.g. I run an app called LFC Buzz. It shows me Google ads. NOTHING shows up in the blokada activity window, under either recent or top. NOTHING!

What on earth is going on?! How can I debug this?

to make posting more easy, we created a guideline for you:
Please always include which platform you are on: Android or iOS. If you have a question about features feel welcome to ask it - if you face a problem, please follow this template:

Title: please select a meaningful title!
e.g. Blokada for Android doesn’t block ads in my-little-farm-animals app

To directly help you the best way possible please provide the following information:

  1. Where did you download Blokada from?
  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
  3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
  4. Since when are you facing this issue?
  5. Did you already try to solve the issue somehow? If so: please state what you did.
1 Like

Sorry, and thanks for the reminder.

I download it only ever from your website.

I’m using a Mi Max 3 running the latest android / MIUI.

The difficult thing is that I did nothing different, apart from download the latest version of blokada.

After enabling different lists, and getting no change, I deleted it and downloaded it again. No difference :frowning:

Did you double-check whether or not private dns is set to “off” in your system settings? Miui tends to mess with this

1 Like

Thanks for that idea, I’ll check now.

1 Like

That looks like it worked! Thanks very much, that’s wonderful! I turned it off, and it now works. I’ll file that tip just in case something happens in the future.

Is this in the blokada doco somewhere? Maybe I didn’t search carefully enough before.

Thanks again!

1 Like

It all depends on which blocklists you’ve activated. Otherwise you may have to blocklist some domains yourself

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.