Blokada ignores DHCP-supplied DNS server


Using a Moto G5SPlus with Android 8.1, with 4.x I had (past tense) a weird issue: after the first time I used Blokada, IPV6 would be shot until the next reboot. I would get an address but it would be unusable and the usual checksites would return a score of 0. Reboot, all worked again.

For this reason, I decided to try 5.x and noticed that 5.6 in the Changelog mentions more IPV6 fixes, so I gave it a spin: downloaded it directly from the official source and started it up, gave permissions, activated.

The issue is: nothing gets through. As long as 5.6 is active, I might as well be offline. The moment I turn off Blokada, all is well again and the IPV6 checks pass with flying colours.

I thought the problem might be not choosing any blocklist, so I picked the first from the list and activated it. Still no luck.

Since there seems to be no flurry of bugreports / comments on this, I’m inclined to believe I’m doing something wrong. Anything in particular I should check? In the activity panel, I see almost all items as green.

Thanks in advance,

Did you disable Private DNS in your system settings?

1 Like

I uninstalled 4.x and installed 5.6, nothing else: if the settings are inherited, I have no recollection of the changes made over time. Where should I look?

Actually, there is one more thing: I’m blocking all external DNS queries at the router level, that is LAN hosts (phone included) are only allowed to query the local resolver, no DNS through traffic. I’ve temporarily disabled the rule and magic happened.

So, now the question changes a bit: how do I tell Blokada 5.x to stick with the DNS server provided via DHCP? Other than that funny glitch, 4.x was running fine with the “no external DNS” rule in place in the firewall.

1 Like

I’m running Android 8.1, I doubt this applies to me.

It’s possible though

There is no GUI for this in 8.1 so it doesn’t seem likely.
I had a quick look in the forum and this seems to be a recurring issue with no solution yet, by design.

To wrap it up, I’m going back to 4.x until the situation improves.
Thank the tip, it forced me to think about the local network environment and pointed me in the right direction.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.