Blokada behind pfSense

to make posting more easy, we created a guideline for you:
Please always include which platform you are on: Android or iOS. If you have a question about features feel welcome to ask it - if you face a problem, please follow this template:

Title: please select a meaningful title!
e.g. Blokada for Android doesn’t block ads in my-little-farm-animals app
Running Blokada behind pfSense
To directly help you the best way possible please provide the following information:

  1. Where did you download Blokada from? Blokada website
  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
    Android Lineage OS 17.1
  3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
    I’ve recently upgraded my router to pfSense, and I noticed some apps not working on Wi-Fi but do work on cellular. I even reset the settings for blokada, and with no block lists and default settings they still don’t work.
  4. Since when are you facing this issue?
    Since I changed my router to pfSense

If you’re using 5.x go to:
Advanced → Networks → → and hit prefer network DNS

Hey and thanks for your reply. I am using 5.18, but that feature can only be applied to all Wi-Fi connections, and not to a specific Wi-Fi, as I don’t see a list of networks there.

Press the tiny question mark. Blokada will then do what it tells you it’ll do xD

I did, only my specific cellular network showed up, not my Wi-Fi. Also this solution did not help, I changed the “Any Wi-Fi connection” to prefer network DNS, and still the apps refuse to connect. If I turn off blokada or if I switch to cellular data, they work.

Have you been connected to that WiFi at the time?

No, I was connected to my cellular, but I also checked once I connected to my Wi-Fi, and it did not appear on the list.

Anyway, that’s not a valid solution. It does not solve the issue.

If the dns would be advertising properly locally and your android was able to collect the network connections properly and would properly hand them over to blokada, you’d see a list of all networks and could set specific networks to use your network dns.

This is the one and only possible solution. I don’t know whether or not Lineage OS might be the bottleneck here. We cannot support custom ROMs properly since they’re not guaranteed to be as thoroughly tested as the original OS.
Well look into this further.
Please note that it’s currently weekend

Just to clarify, the same ROM and version of blokada worked before I switched to pfSense as my router. So I’m not sure if that has anything to do with it.

Also, my current workaround is to just bypass those apps for all networks on an app by app basis.
It’s ok. there’s no rush, I understand it’s the weekend, I’ve been dealing with this issue for a while now, I can wait.

This seems super strange to me, but also I don’t use Android myself :slight_smile:

Could it be possible that your pfSense setup is blocking DNS requests out to the internet and the network config to use the local DNS doesn’t really work?
Maybe if you play around the firewall settings to check if some outgoing ports are blocked, maybe there’s a logging feature you can enable to try to see if something shows up while the broken app is trying to connect

Hey, so the pfSense does not block requests, some apps work fine, and I have internet connectivity. Also, if it blocked requests, it would not work even when I turn off Blokada.

I mean that pfSense might block Blokada from sending requests to an external DNS, in case the network settings to prefer local DNS doesn’t get applied as intended.

Try both with “encrypt dns” and without it as well

I tried every combination of the options under Wi-Fi, thinking maybe the encryption was what was causing this, I have not found a way to make it work aside from deactivation or bypass.

It really should have a full list of networks your phone knows about unless your permissions are wrong. Or ROM is blocking it.

You are really focusing on the wrong path here. I already told you that even setting everything for all Wi-Fi networks does not solve the issue, so whether I have my Wi-Fi appear is a separate issue.

Well… But one could also say that if even that doesn’t work properly, why should the other setting work properly?

I haven’t read the code for this, but I assume these can be 2 unrelated issues. I’m guessing only a dev can answer that.

Considering how “serious” pfSense is the only thing that comes to mind is it’s forcing DNS through itself.

But if blokada is still broken after turning off encrypted DNS for your home network I dunno.

Considering pfSense does not handle DNS on my network, it just forwards the requests to PiHole that worked before with Blokada, that’s not the path to go down in my opinion.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.